ROCK: Log-In not possible

Core Machine

ROCK installed on NUC8I5BEH, 8GB RAM, 256GB SSD (Serial #1C697A6A6FEE)

Network Details

NUC connected directly to router (Vodafone Cable Router “eMTA DOCSIS 3.1 Technicolor W-Lan Evolut”) via Ethernet.

Description of Issue

Log-In on ROCK Core is not possible (see picture below).

Roon was originally running on Windows Core. Back-up created on USB-hard drive. After disconnecting the Windows Core in Roon it’s possible to choose ROCK as a core. Restoring of back-up from USB hard drive (connected directly to NUC) was also successful. After restoring of back-up a restart was necessary. Then I got re-directed to Log-In screen again. I entered my Log-In data but after waiting for 1min an error message appeared “network error: please check your internet connection”.

There is no message that my license needs to be transferred to ROCK or anything else.
I can access to ROCK on my Windows PC (\ROCK) as well on the browser by typing in the IP-address.

I found that Thierry_Moulin also had the same issue in Dec '20 but I didn’t found a solution.

I hope you can support. Thank you very much in advance.

Have you tried rebooting your internet router? That has been known to cure this issue on occasion…

Thanks, Geoff. I already tried to reboot my router (and ROCK OS, database and server). Without any success.

It’s odd. If I’m reading your post correctly, then you’ve:

  • created a new Roon Core on a ROCK/NUC
  • used Roon (running on Windows, I presume) to connect to the new Core
  • got the Login screen on the ROCK/NUC Core
  • used the link at the bottom of the screen to restore a Backup of your previous Core
  • rebooted the ROCK/NUC
  • you still see the Login screen…

That last step is the odd one - I would have expected that you would have got into your new Core (running the database and login credentials restored from the Backup) straightaway. You shouldn’t be seeing the Login screen for a second time.

I’m out of ideas. I’m afraid we’ll have to wait for Support or someone else to chime in.

exactly. I would also assume that I should be reconnected directly to Roon once the backup has been restored and don’t understand why I see the log-in screen again.

Let’s hope that support will find a solution next week. Thanks anyway for your effort and have a nice weekend.

1 Like

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Are you still seeing issues? If so, can you try using Google DNS or Cloudflare DNS? Does that help?

Hi Dylan

I tried to change to Google DNS but now I can’t access Rock Web UI anymore.
The NUC says I can access it under - but my Browser is not loading the Web UI.
Seems I had something wrong and safed. Is there a chance to reinstall ROCK on the NUC without having access to the Web UI?
If so, how can I properly set Static IP to Google DNS to check if I can change my Roon Core then?

Sorry for the trouble and making it even worse. :slight_smile:

Thanks for your support in advance.

I think what you have done in the Web Administration Page is to save the Google DNS address ( into the IP address field of your ROCK, instead of into the DNS Server field.

Reset your network address using this Help article:

And, is there some reason why you want to have a static address in your ROCK? Best practice would be to use the DHCP server in your router, and reserve an IP address in your router for the ROCK/NUC.


I think @Geoff_Coupe is on the money, you’ve inadvertently set ROCKs IP address to…

Having reset the network settings per Geoffs link, open the web admin page and note the IP address, Netmask, and Gateway settings… Press the static tab, and re-enter these exactly. In the DNS server box, enter Reboot. Don’t mess up the numbers, lol.

But Geoff is right, DHCP exists for a reason. Only leave it set like this if the DNS change is necessary.

1 Like

Hey @Alexander_Raasch,

I was wondering if you had any updates to share with us about this, or, if we can help with anything at this time? :nerd_face:

This topic was automatically closed after 45 hours. New replies are no longer allowed.