ROCK losing Primare DAC30 USB DAC

While setting up the Roon Core Server with the Roon App there was some software „confusion“. I received a notice that the Roon Essentials core must be removed first. While reading the error text further, the setup did finally continue normally.

The rest didn’t take long & I was listening to my music library from my NAS over the Intel NUC (Intel NUC i3 - 4010U - 4GB RAM - 60GB mSATA ) via USB 2.0 connection to my DAC (Primare DAC30) within minutes. The Roon software is also much faster than that of the ELAC, not to mention the many more options available.

I was/am very impressed with the sound quality compared to that of the ELAC Discovery Music Server via COAX/Optical (no USB In). I am, however, experiencing major problems with the USB connection while streaming from NAS, TIDAL & Qobuz! During playback, the USB signal periodically appears to vanish (no sound but with audio signal still running) although the USB device is still active in the Roon device settings. The Signal path, however blinks.

Even though I changed the buffer size from default to 50ms and then to 500, as advised in your „Audio Setup Basics“, there is no improvement on my situation. Unfortunately, the only solution to this problem seems to be a restart of the Roon Core or the DAC. This, however, is only very temporary.

  • Roon OS Ver. 1 (Build 227)
  • Roon Database = 90% of 51 GB available
  • Roon Server Software Vers. 1.7 (Build 610)

I’ve turned off the ELAC DMS and deleted the App on my iPad Mini 5 for further testing assuming the DMS and/or Roon Essentials are possibly causing this issue. Unfortunately, the problem still exists.

Can you give me any further advice, tips, etc. to locate and solve this problem? Otherwise, I’ll just have to go back to Roon Essentials :frowning:

I’ve also asked Primare AB for assistance regarding this issue. No answer yet.

tried a different USB cable by chance? Is it a USB powered device? if so maybe the USB port doesn’t have enough power to drive it?


Sorry, forgot to mention that. Yes, I tried a cheap, normal USB printer cable, too. The result remained the same.

Just for the records, I’ve been using the Wireworld Starlight 7 USB cable w/o problems for years (from MacBook => old/new DAC) although not together with Roon because the ELAC DMS doesn’t have an USB in and I didn’t have a full Roon setup until two days ago.

No, both the DAC and the NUC has it’s own power supply & doesn’t rely on the USB connection.

Come to think of it, I didn’t try one of the remaining USB 3.0 ports on the NUC! I’ve just done it and will monitor the outcome today.
Didn’t take too long!: USB 3.0 has the same problem :frowning:

Hi, Has Roon finished the audio analysis of your music database, just wondering whether it been an early NUC that resources maybe marginal???

Yes, this problem is occurring while Roon has completed the music library scan (approx. 30,000 tracks). This problem also arises while browsing/listening to TIDAL & Qobuz.

Can’t imagine that this may have to do with not enough NUC resources because the software and hardware are reacting very fast. It seems to be an USB issue.

BTW: USB 3.0 has the same problem :frowning:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

I’ve been having no further problems since yesterday morning after refreshing the NUC’s BIOS and changing 2 audio settings:

  1. changed USB Configuration from “USB Legacy” to “disabled”
  2. changed XHCI Mode from “Smart Audio” to “disabled” (USB 2.0 is better for audio anyway!)