ROCK misses first milliseconds of begin of song

Probably since the last update of ROCK (build 242) I have noticed that the very beginning of the music is skipped when you push the Play button. It is just a tiny little bit, some milliseconds. When the music starts with a fade in, you don’t hear it.
However, when the music starts immediately, staccato, full speed, you hear it.
When the music is already playing, and goes to the next song, the playing starts from the beginning, no skipping.
I have this issue when I play the music direct via the speakers of my computer (client Roon) and when I play it via the NUC ROCK server, connected wired (usb) to an amplifier. It happens with all file types, FLAC of MP3 etc. and bitrates.
When I listen to such a song with a ‘skipped start’ in an audio editor, the start of the song is present.
Here’s an example of playing Tommy of the Who via my amplifier:

Hi @Arie_van_Boxel ----- Thank you for the report and sharing this observation you’ve made with us. The insight is always appreciated.

Moving forward, are you using our “resync delay” feature, by chance? If not, may I ask you to please give it a go.


Yes, I have tried “resync delay”. Even at 5s the first milliseconds are skipped.

Hi @Arie_van_Boxel ----- Thank you for the follow up and verifying that information for me.

Moving forward, may I kindly ask you to please provide screenshots of the playback settings you are using in Roon with the NuPrime IDA-8.


I really feel this is happening to me with the sMS-200 as well. I have resync set to 500ms in Roon and on the sMS-220 config page.

Resonessence Invicta Mirus Pro DSD128 DOP. Roon is doing the upsampling.

Hi @DrTone ---- Thank you for chiming in here and sharing your feedback with us. Very appreciated!

Moving forward, can you please provide…

  • The details of the device hosting your Roon core.

  • A screenshot of the signal path leaving the application when this observation is made.

  • A screenshot of your device settings you are using for the sMS-200 zone.


Sorry for the delay. Here are my playback settings:

Hi @Arie_van_Boxel ---- Thank you for your patience, while I have been discussing the next steps forward with the team. Out of curiosity, during your troubleshooting have you tried with a different connection between the NuPrime IDA-8?

Furthermore, do you find that this issue is occurring when trying to playback a specific sample rate? Or does this appear to be a more generalized behavior?


I have tried an analog connection, but the issue remains. However as far as I can see it happens only with the .flac format.
Good examples from my library are

Tommy, The Who, FLAC 96kHz 24bit


Human, Rag ‘n’ Bone Man, FLAC 44.1kHz 16bit

As you can see, the start of the song has to be very sharp.

Some extra info.
I have used an optical connection (Airplay via an Apple Airport) and then there is no problem. Of course then there is a 3-4 seconds delay before the music starts playing.
It could be it has to do with the NuPrime IDA-8 and not with ROCK…

Hi @Arie_van_Boxel ---- Thank you for sharing these observation with me, very appreciated!

Would you be able to provide me with one of the mentioned flac. files from above via a dropbox download link for testing?


Sure. No problem.

1 Like

Hi @Arie_van_Boxel — Thank you for the follow up! Confirming that I have seen your PM and that the content has been downloaded successfully. I’ll let you know what the team comes up with!

Your patience is very appreciated!

Hi @Arie_van_Boxel ---- I just wanted to to give you a quick update and let you know that our techs have now taken over testing with the provided media, and will let me know what they find after they’ve completed their analysis :microscope: