ROCK New Install - Won't Play MP3 Files

Yesterday I switched from from my linux-based roon server to an Intel NUC with ROCK installed.

The install was no problem and restoring my backup of roon worked perfectly. Everything seemed to be working right until I tried a couple of radio stations. These stations stream mp3 files and when I tried to play the station I got a “transport: failed to load media” error.

I believe the problem is related to the ffmpeg codec. I tried the codec suggested when you click on the “missing codec” link. I still had the problem. I then tried several other versions of the codec maintained at the website, and didn’t have any luck.

Any suggestions.


Hello @Brad_Beeson,

Can you please post a screenshot of where you dropped the ffmpeg file and the source you got it from?

These instructions should still be valid, and you would need to “unzip” the archive first using 7zip so that a single ffmpeg file is available and then place it in your ROCK Data Directory/Codecs folder.

I would reboot your ROCK after placing the file there as well and verify that the message does not appear in the WebUI. Please let me know if that helps!


First thanks for the quick reply. On a Sunday. I’m impressed.

So I downloaded the file from below

And then I opened the file using 7-Zip shown below

I should note that before I was using Directory Opus to open the file. Using 7-Zip seemed different, but I couldn’t say how.

Then I copied the file to here


After rebooting the ROCK I saw this


This is the first time I got the “OK.”

Just checked my radio stations. Everything is working great.

The problem must have been because I didn’t use 7-Zip.

Again, thanks for the help.

Glad to hear that the issue is resolved :sunglasses:. Thanks again for contacting support @Brad_Beeson and hope you have a great new year!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.