ROCK - No Album art and Qobuz don't work

Hello ,
the following problem:
I have been using my Mac Mini M1 as Roon Core so far and it works very well.
Now I wanted to try Roon Rock and bought an Intel NUC8i3EBH.
8GB RAM, 128GB M.2 SSD.
The installation goes without problems, however I can only listen to music via TIDAl, Qobuz does not work, and no album covers are loaded.
I have now already reinstalled Rock, all without success.
What can this be?
I have not imported albums, but only use Tidal and Qobuz.

Back to the Mac M1, all works well:

Qobuz also works.

Before we dig deeper, check dns settings. Try or, then reboot your core and your remote.

Report back after trying.

Hi danny,

thanks for your answer.
I tried both - and, then restarted the router and Core/Remote, but still the same.
No Coverart, and Qobuz don’t work.
Tidal works.

please PM me the email you use to login to Roon.

pulled logs… your dns is fine.

however, qobuz streaming is being blocked (or something else)… the requests are timing out.

is it possible you have software on your mac that is helping qobuz be more friendly here? like a vpn or an exception in a router firewall?

No exceptions nor vpn.
I ordered a new M2 SSD and Ram Kit, should arrive on Wednesday, maybe it helps.

If something doesn’t work and I can’t explain it, I might go crazy.

NUC Core deactivated again, Mac Mini activated, everything runs without problems.

I read that the M2 SSD installed in my NUC is apparently very slow,
so i ordered an M2 SSD from Corsair, with 240GB, as well as new RAM, also from Corsair, 2 x 8 GB.

If all that doesn’t work either, I have a NUC to give away…

1 Like

It’s not too small, but ok. Your ram is good too. Upgrades cant hurt, but you arent in bad shape with the current gear.

I’ll check this out a bit deeper on Monday, we should be able to get this working.

1 Like

So, from my side, I give it up…

I’ve tried everything possible, hooked the NUC directly to the router, completely formatted the SSD, and reinstalled Roon Rock, deleted and reinstalled all Roon apps, all to no avail.

I also assigned a fixed IP to the NUC, and tested various DNS servers -,,, all without success.

Lastly, I connected the NUC to the LAN cable that my Mac Mini M1 is normally connected to, also without success.

Oh, furthermore, I even completely disabled the firewall in my router, all to no avail.
So I guess I will have to stay with my Mac Mini…

The only thing I can think of now is to replace the cheap standard router from my internet provider.
Have now ordered a FRITZ!Box 6591 Cable, last attempt so to speak.

You are getting a lot of network timeouts to many things, not just Qobuz.

This is very strange. Can you explain what your network is like and what your connection to your ISP is like?

Router → Switch → Patchpanel.

Then it is distributed in the apartment, in each room there are 1 - 2 connections.
My internet connection is actually very fast, I have a 1,000Mbit/s line, fiber optic cable.

But there is no problem with anything else, Netflix in the living room runs wonderfully, internet radio, Roon via Mac Mini, Win PC, …

Would you like to see how it looks now with the timeouts?
Because currently I have my Mac Mini again as a core in operation, and everything runs perfect.

I have now ordered a Fritzbox as described above, there I have full control over all inputs and outputs, with my current router I can not set anything manually.

The download speed is very good, I am currently streaming music from Qobuz, and the wife is watching Netflix, and yet I have such good values.

What’s your switch? Managed or unmanaged? (grasping at straws here…)

I’m pinning all my hopes on the new router - it should be here by the end of the week.

are you using the m1 and the nuc with the same patch panel port and cable?

I’m positive you don’t have internet issues (DNS or outbound traffic). The timeouts seem random.

Images are a major ongoing download, so it makes sense you have random failures there, but the fact that qobuz never works is very strange.

Yes, the Mac is on the same line.
With the NUC I have permanently no album art, but at least playback from TIDAL works.
It’s a mystery to me myself.

It is my pleasure to announce that Roon Rock now works for me.
In case someone from Germany with the internet provider Vodafone has the same problem, here is the solution:

The standard Vodafone router does NOT work!

Today my FRITZ!Box 6591 Cable arrived, I set it up and IMMEDIATELY everything works wonderfully.

Unfortunately, I can’t say why that is.