ROCK NUC feeding USB direct to DAC will lose audio when new changing song


I am running latest ROCK (Version 1.0, Build 159, same issues on 158) on an Intel NUC7i5 connected via USB to a Holo Cyan DAC/Headphone amplifier (uses XMOS xu208 for USB)

Setup has been running fine for a few weeks, but lately running started running into an issue when I skip to the next track I hear a crinkly/static noise in my headphones, audio cuts off, and the Roon keeps playing the song and the DAC registers the bitrate still coming in but no audio comes through

If I cycle through the inputs on my DAC and come back around the USB then Roon and audio will re-engage with the DAC. Otherwise I need to reboot the NUC or unplug/re-plug USB

Doesn’t happen every time I skip a song but will happen within ~10 song skips, very repeatable incident. Happens most often on skipping a song whether jumping through album or playlist, and especially when playing Roon Radio, but sometimes even happens when I just select a new song to play - same static noise and cut out

All my audio is stored locally on a MicroSD card that is on a USB adapter plugged into the NUC. I have tried a different card adapter and swapped around to various USB ports for both storage and USB feed to DAC and issue persists on different ports

Have tried different USB cables as well. DAC was bought new very recently so unlikely the USB connection there is bust

The NUC is running ROCK and controlled via Wifi remote on my Macbook air or iPhone, issue happens with either remote source

Pretty small library with a little under 3,000 tracks total, ~95gb mostly all FLAC

Intel NUC is 7th gen, i5 processor, 8gb of ram, 120gb M2 internal SSD for OS storage (NUC7i5BNK)

Using my Macbook Air as a Roon Core I don’t get this issue at all even using same MicroSD card, adapter, USB cable, DAC/AMP and headphones

I have reinstalled ROCK from the online access page as well as done a fully manual reinstall from USB boot drive. Issue persists after both re-installations

So my troubleshooting has narrowed the issue down to ROCK or the NUC but looking for any help beyond that?

Hello @Jojo_Man,

Thanks for contacting support and providing a comprehensive list of what you’ve tried so far. I have a few other questions that may help here:

  • What is your router model/manufacturer? Is the ROCK connected via Ethernet directly to the router or are you making use of any switches/range extenders/powerline adapters here?

  • Can you try to temporarily disable Audio Analysis for both the background and on-demand analysis to see if this changes anything?

  • Have you rebooted your ROCK and networking gear yet? I would do that as well if you haven’t yet.

  • If you connect a flash drive via USB instead of using the MicroSD card, do you still experience the same issue? You don’t have to load all of the tracks on the flash drive, just a few to see if this changes anything.

  • I have also gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

  • I kindly ask for you to reproduce this issue once or twice more and then let me know the exact local time in your country (ex.1:20PM) that you notice the issue and the local time in which rebooting the DAC resolves it. I will then take a look at the diagnostics received to see if there are any errors outputted around that time.

Please let me know the above when possible.


Hi Noris, thanks for getting back so quickly

Definitely some good troubleshooting ideas here - I will be able to test some of these out later tonight (past 8pm EST) and will respond back with exact times to help with diagnostics if issues still occurring

ROCK is not connected via Ethernet, only wifi, my router is a SmartRG SR400ac

(No range extenders or anything, router reaches fine to devices even further away in the house than the NUC)

Will try rebooting all network gear this evening as well and load a flash drive with some music and report back


1 Like

If you have a simple way to wire your ROCK to the ethernet, if only for a while, I would start there. My hunch, and it’s only that, is that your ROCK 'n ROON would benefit from being wired.

Good luck to you. Been there.

Okay so tried to replicate the issue first without changing anything, same old setup and reproduced the issue at following times (all Eastern US time)

10:17pm, 10:18pm, 10:19pm

I turned off Audio Analysis (both background and auto) and still getting same issue - 10:20pm

(As happened here - if I hit skip again or hit pause in Roon it will start automatically skipping instantly through songs in the rest of the playlist/album/radio)

Removed microsd adapted and tried a reliable USB thumb drive with a few albums on it, same issue at 10:24pm

After all these times it cuts out I cycled through my DAC’s inputs and go back to USB in order to get Roon/ROCK speaking with the DAC again

Also, I am realizing I misspoke on one point earlier, when this audio cut out happens, my DAC screen goes from displaying the bitrate to displaying “----” which is what it shows when no source is connected or source is off

Going to shutdown router, ROCK and audio gear now and reboot after a bit, will report back if issue is solved or persists

Appreciate the advice, even on just a hunch!

Wired is a PITA for my current setup and hoping to avoid it as I am technically only using Wifi for control, not transfer of data - but I will definitely try running a cable to my router temporarily for troubleshooting purposes when I get the chance

Reporting back!

Rebooting network didn’t help unfortunately, same issue at 11:03 and 11:05pm

Current (possible) breakthrough - up sampling everything to DSD128 (via Roon natively, no HQ player or anything) seems to be curing the issue (skipped a bunch with no issue, cant say its gone for good though)

I was running this up-sampling DSP for the first few weeks so possibly that’s why I wasn’t running into the issue

This leads me to believe maybe its a (changing) sample rate issue?

Played a bunch of only 44.1/16 bit FLAC and didn’t encounter the issue

But then went back to randomly playing and watched as a few other sample rate tracks came up and no effect

The issue was actually much less frequent now for whatever reason, only got it to occur once again, and couldn’t catch if it was a changed sample rate track

I am calling it quits on experimenting for tonight but hopefully the diagnostics provide some info

If I get a proper listening session in later tonight I plan to up sample to DSD128, so will see if I encounter the issue under same playback chain/conditions but with DSP enabled

With DSP disabled, and using non-MQA PCM music, try these transitions between previous track from/to next track:
44.1kHz <-> 96kHz
44.1kHz <-> 192kHz
44.1kHz <-> DSD64
44.1kHz <-> DSD128
96k/192Hz <-> DSD64
96k/192Hz <-> DSD128

Hello @Jojo_Man,

I appreciate your patience here while we internally discussed your case. We’re aware of some issues with DACs that use the XMOS chipset, and we are currently looking into whether this is something we can resolve with a change in Roon.

The ticket is open in our tracker and we’re hoping to make some progress soon, but for the moment I cannot provide a timeline of when a change might happen here. I will be sure to update you as soon as I receive the report back from the devs regarding their findings, I appreciate your patience in the meantime.


Sounds like the same issue again of Roon/rock/nucleus not coping with switching bit depths in Linux. The only cure I found was upsampling all PCM to one sample rate bit depth. On my system it couldbt hack going from 44.1/16 to 44.1/24 other player software on same endpoint no issues.

Thanks for the follow up, Noris - glad to hear it is on your radar

I have had a few listening sessions since, all the while up-sampling to DSD128 and haven’t encountered the issue again so no worries on a quick fix as I at least have a temporary fix to keep the music going while you investigate a root cause

When I get the chance to do some more experimenting I will pull together various tracks to test changing between different sample rates and bit rates as suggested by wklie and simon to see if I can help narrow down the issue at all

Appreciate the help, all!

1 Like

Sounds very like the issue we’re experiencing with our Singxer SU-1 DDCs. I believe they use an XMOS208 chipset.

If you stay at the same sample rate, say 44.1 but change bit depth from 16 to 24, does it always trigger the issue?