ROCK on Intel NUC8I5BEH network losing connection?

Hi guys I’ve bought a intel NUC8I5BEH with 8 gb hyper x memory and a crucial p.2 m.2 ssd nvme drive.
I firstly updated the bios and installed rock and configured the bios as in the rock instructions.
It’s working great apart from after a few hours or so or overnight losing network connection, it’s connected by ethernet as is my oppo udp-205 which i use for the dac for roon amongst other things in the house, any ideas why it can be losing connection.?
There’s no playback problems!..

Hi guys Ive bought a intel NUC8I5BEH.
I’ve installed 8gb of hyper x memory with
Crucial P2 250GB nvme ssd.
I installed rock on it as instructed in the help guide and also updated the bios previously before installing rock.
It all works fine connected to my nas… connected to my oppo udp-205 usb dac and the roon ready ethernet part.
Also useing 2 sonos play 1 speakers with it.
Problem is several hours after useing it… Or overnight when i go on my tablet or phone i can’t find the roon core.!
I have to manually reboot the intel nuc then it’s fine again… Question is why do u need to reboot the nuc.?.. Any ideas.?

Is it just your tablet or phone having issues? Meaning if they cannot connect, can you connect with a normal PC running Roon connected by Ethernet? It may be the situation is corrected by rebooting the NUC, but, the issue might be something else.

When the tablet can’t find the Roon core, if you get to a screen that has a blue HELP link, if you click it, it will allow you to enter the IP address of the core. Instead of the actual address, if you use that might help you connect and stay connected.

Well I’ve tried giving the nuc a static ip address on the router… It just seems to lose connection, my tablet and phone seem to be working fine although i haven’t tried connecting by my desktop computer which is connected by ethernet I’ll give that a try next time… My nuc is on a ethernet switch i don’t know if that makes a difference as there’s only 2 ports on my sky q broadband router so one goes to the living room from the router on a 5 ethernet switch and the other one goes to my listening room where the nuc and other components are all connected on a 8 port ethernet switch.!..
I’ll try changing the ip address to
And see what happens first and report back ! Thank you

Just to confirm that the 255 addresses you enter into the clients that can’t connect. Not in the server.

1 Like

I tried to connect this morning once again and it won’t, so this time i tried to connect by my desktop computer which is also connected to the network on ethernet and it couldn’t find it… I looked on the sky router and it is listed as rock connected.!
When i put in this… Are you saying i put this in the roon client such as my phone and tablet… So I’d put it in the router as a static ip.? Or in the phone settings.?.. Not sure where you mean?

The above screenshot is what I’m getting on the ip address page of the nuc.!

Well, that’s definitely not going to work. That’s not a valid IPv4 unicast address.

Where did you get this address? Also, what do you mean by “losing network connection”? What symptoms are you seeing, and how do you recover from this condition?

1 Like

The is what’s been suggested above but haven’t even tried it yet, i usually recover by rebooting the nuc with the front on/off switch.!..also tried rebooting the router as well but that didn’t work.!

No the 255 goes into the client when it times out after not seeing the server. Don’t put 255 into the server.

Exactly where do i put it.?

Any ideas anybody.?
You don’t think there could be any problems with the hardware I’ve selected by the way listed at the top of my post.?
Thanks in advance.

Just to add… I have the nuc connected by ethernet to a tp link 8 port switch… Should the nuc just be connected by ethernet straight to my sky q broadband router.? If this is the case then i need to change my broadband provider as sky q only has 2 ethernet ports.!

I tried it overnight last night on a single ethernet lead to my sky q router but this morning tried it and was inaccessible again… In yet I’m positive there’s nothing wrong with the router or cables.!
. Making me wonder if its something to do with crucial p2 nvme 250 gb ssd.!.. In yet it boots up OK when i reboot the router very puzzling. … Beginning to wish I’d stuck with my unraid nas drive as that always worked OK

It sounds like some sort of network discovery problem. The core remains working, but once the client devices have been lost from connection the core can’t find them again. There are some points to consider in this part of the Knowledge Base.
Roon Networking Best Practices (

In particular, pay attention to the IGMP settings in your Sky router. You may need to turn on IGMP Proxy and turn off IGMP snooping. Also, managed switches can cause issues. You don’t mention if your switches are managed or unmanaged switches.

It sounds like you had Roon running previously on a NAS and that worked fine?

If none of these suggestions work, we should probably move your post over to Support. I really don’t think it’s your NUC, but rather some networking issue. For that reason, it will be easier for Support if you explicitly describe your network so they don’t have to scroll through the thread.
If you want to move this to support, I can do that for you.

But you really need to keep IGMP snooping on if you can for best network performance, especially with Roon… if this does make a difference search for the most recent firmware on your router or motherboard BIOS as it may have a bug or interworking issue with your Rock firmware or OS (for the IGMP implementation) . Some consumer routers these days have IGMP snooping on as standard and you can’t disable as it’s a fairly key function these days… especially with service providers offering multicast IPTV.

From memory: after a period of trying to correct to the core and pointing out that it’s taking longer than usual, Roon on the client asks if you want some help. Click on that and I think you’re then offered the choice of connecting to a different core. Agree to that and you get a warning about losing the music you had ( or something equally scary). Agree to that as well and on the next screen you get the option of entering an IP address to go to. That’s where you can enter the No, it’s not an IP address but it points the client to the right place and Roon opens like it had never been away.

It worked for me on a Sky router and connecting via an android phone over a TP Power line wireless device plugged into the mains. Lots of barriers to cross there :thinking: but it sorted out a persistent refusal to connect to the core. As I say, that’s from memory and could well be in a different order, but you probably get the idea.

My NUC is also connected to an unmanaged switch, by the way.

The ethernet switch I’ve got is the tp-link ts-g108… I believe its a unmanaged switch but not 100%, I’ll take a look at the sky router settings and check them out and see, I’ll also try the next time my phone or tablet won’t connect… I’ll try the above suggestions before i move to roon support… Thanks guys for the help much appreciated