Rock on nuc5i5 not booting with external SSD

Roon Core Machine

Nuc 5i5ryh, freshly updated to Bios RY0386
Rock installed on new Crucial M2/256 GB
BIOS on UEFI (which is also recommended for Rock 2.0)

Networking Gear & Setup Details

Netgear switch

Connected Audio Devices

Network > nuc7i7 > USB DAC

Number of Tracks in Library

20000 tracks

Description of Issue

When booting with external USB SanDisk extreme SSD 2TB, Rock does not boot.
As soon as I remove the SanDisk, Rock boots.
When using a normal external USB harddisk (WD, 2TB) Rock boots normally.
I already formatted the SanDisk SSD, but that didn’t work.

Maybe someone can help me?

Regards, Rem

What Boot sequence do you have specified in the BIOS? You should have your M.2 SSD first in the sequence.

Hey Geoff,

In UEFI, there is only one bootable device, the M2 ssd.
In the bios, I disabled boot from USB also.

Regards

Remco

But the instructions I quoted above explicitly state to enable USB Boot. I realise that this is so that the initial installation of Roon OS can be made from the ROCK USB stick, but still - it implies that having the USB Boot enabled should not affect a working installation.

What format is the SanDisk SSD using, and how have you formatted it?

What happens if you boot and then plug the disk in? Does it freeze? My suspicion is current draw is high. What power supply are you using?

Geoff,
That’s a good one. I will try if switching “Enable USB boot” on again.
The SanDisk was on NTFS, tried exFat also, but same problem.
After tooling at the SanDisk SSD, it doesn’t get recognised again, will have to look into this.

The SSD draws very much less current than the WD hard drive, so this will not be the problem.
If I boot without the SanDisk, it boots up normally.
If its plugged in at boot, the boot halts and only resumes when unplugging the SanDisk, after which I can plug it in again, when Rock is running.

Thx for all your input

Remco

I can’t see how USB boot would be a solution, that’s not even what you want to do. Enabling the machine to boot from USB wouldn’t affect the possibility to access the usb drive once booted on the m2 ssd?
And also… why don’t you use the nuc7i7 as core and nuc5i5 as bridge instead?

We’re not saying USB Boot “would be a solution”, merely establishing that it is irrelevant to the issue - there’s something else going on (and I don’t know what it is)…

Just a thought: are you using the same USB cable for both drives, or different ones? Could it be a faulty cable?

The SanDisk extreme SSD is giving me some problems.
Changed USB cable /port. Still the same problem. Also, mostly Rock will boot normally, but than the SanDisk is not available. Reconnecting the SanDisk, it becomes available.
No problem whatsoever with Windows 10.
I tried normal USB stick and WD USB drive, which work well.
In the bios, all as should be done.



Should I try Legacy boot and do I need to install Rock again for this?

I use the 7i7 for upsampling for idsd micro, I need the power there.

Regards, Remco

Hi @Remco_Deckers ,

Can you please reproduce this issue and let us know the exact local time + date when your ROCK boot halted? I would like to check your ROCK system log to see if there are any interesting errors after you reproduce the issue.

Hello Noris,

Today 24.jan, I booted at 9:15 (in the log file it says 8.15) and Rock booted normally, but the USB SSD wasn’t visible. At 9.18 I unplugged the USB SSD and reconnected it, than it was visible.
At 9.22 I did a new start of Rock, now it didn’t boot at all. It came to a halt. After unplugging the USB SSD, Rock booted normally and after the boot, I conncted the USB SSD and it worked normally.
I leave the Rock running for now with the USB SSD connected. I will be able to reconnect my normal USB HDD after work.
The Log files before today where done with a normal USB HDD.

Regards, Remco

I’ll ask again. What PSU is being used. This smacks of a power issue.

Henry,
I use the standard PSU of the nuc. As I have 2 nucs, I also tried the other PSU, which didn’t change anything.
Also, a ssd takes much less power than a hdd.
A friend suspected that it could be that the controller of the ssd, which could be not recognised (reliable) by the USB controller of the quite old nuc…

Regards

I use a 5i3 and previously owned the 5i5 which I believe is still in use in a friends setup (both the MYBE variant). I don’t understand why something might be missed during boot, or even cause boot to fail but be just fine if plugged in after that boot sequence. I would remove USB from any boot sequence and try different bios options to see if that helps. But at the back of my mind I am still thinking power! Hopefully you will resolve it to your satisfaction!
My library is on board, I’ve made a point of avoiding USB connection but I will connect my 2TB SSD and 5TB HDD (movies) and see what happens!

Thx for your input.

I’ve tried several bios settings, but it doesn’t help.
As stated, I think the controller is not working properly with the USB SSD.
Power will not be the problem, as I booted with 2 external HDD on it, which was no problem.
I think I will go SSD internal, that is a good tip from you.
I have a Akasa case, so I have room for that and it will be better than the external USB…

Regards, Remco

Hi @Remco_Deckers ,

Do you by any chance have multiple partitions on your Sandisk drive? Was it ever used as an Operating System drive in the past? If you have a hidden UEFI partition on it, this can sometimes happen, I would inspect the drive with Hard Drive partition software on a PC. Or if you go for the internal storage solution work, that can work as well.