ROCK on ProxmoxVE

Inspired by the Rock on ESXi post, tonight, I successfully managed to install ROCK on ProxmoxVE, which is a very powerful virtual machine platform, I’m using it for my home network and labs.

There are several tips for people want to try it:

  1. you can install via real USB stick, flashed with ROCK img. Just passthrough the USB disk to the VM.
  2. you need connect a physical keyboard to the host machine running ProxmoxVE, then passthrough the USB keyboard to VM as well. You will need it input the 1 in the select screen for installation.
  3. You need two disks, 1 is for installing ROCK, another one is for music file storage. both disk should be connected to VM as SATA disk. ROCK won’t be able to recognize SCSI disk.

that’s it. next is to find a good USB bridge.



I am also considering moving my Roon Server from a MacMini to a VM in a NUC.
Why did you choose to install ROCK instead of just Roon Server over Linux? What are the advantages?


My understanding is ROCK is a highly optimized Linux+ROON Server system(which means a lot of unnecessary service, process, components are removed, which might impact sound quality), the sound performance should be better than normal Ubuntu+ ROON Server, that’s the reason I used ROCK.

1 Like

Somehow suddenly my ROCK instance stopped working. It doesn’t even complete booting. I didn’t change anything as far as I know. In he console I get this:

Searching for network address...
If this persists please check your network connection.

And yet… all my VMs are working fine. I already removed and added the network interface to no avail. I’ll probably will just install it again from scratch :frowning_face:

Did this ever happen to you?


I guess you upgrade the latest roon os. Just shutdown the rock, in the hardware config page, change your network card model to intel e1000, and power on rock again. which will solve the problem.

Seems latest version, it does not support the virtio type network card anymore.

1 Like

Oh my!! Thank you so much for that precious information. I would never have found it! You saved me so much work :slight_smile: Thanks!! How did you find it, by the way?

You are welcome, I met the same problem day ago and solve it by that way:grinning:

1 Like

I guess I was happy that you bumped into it first! And solved it first too! :slight_smile: Thanks!!

I upgraded my Proxmox to 6.0 and Rock works fine.

1 Like

Me too. And switched my file system to ZFS because I added an extra HDD to have RAID1. All smooth!

If you don’t want to use a usb stick you can add a line to your VM’s config file like so:

args: -device qemu-xhci,addr=0x18 -drive id=my_usb_disk,file=/path/to/rock.img,if=none,format=raw -device usb-storage,drive=my_usb_disk,removable=on

VM config files are located in /etc/pve/qemu-server/###.conf which corresponds to the VM number of your Rock VM. Obviously you need to copy the rock img file to somewhere accessible by your VM’s. I didn’t find a way to cirumvent the need of a physical keyboard which is weird but must be something with the kernel Roon is using, I think. Once you make that change to the conf file, boot the VM as normal and hit ESC to choose boot device at the Proxmox splash screen. Hit the number that corresponds to the usb option, for me it was 3. You should see Rock booting to the installer if all worked. Then proceed as normal. You can remove the line from the conf file once installed and delete the img file.

thanks for sharing, this is good for remote operation.

for the keyboard issue, this is really wired. would be great that somebody is able to figure it out.

Just did this install and other than the physical keyboard connection issue went without a hitch. Honestly this is the best way to run Roon Core IMHO. I found a 5 year old HP Z620 with 12 core Xeon 2.6Ghz and enterprise grade motherboard/case for $200 local on ebay. Add a few drives to zfs and instant NAS/VM combo server. With what I saved versus an appropriate NUC I can pay the energy bill for 5 years ;).

Anyone thinking of going this route I highly recommend it.


Hi everybody,

I have issues in including missing codecs within ROCK. I am not using Proxmox VE but may be one of you would have an idea? I have tried changing many settings in the VM without success so far.

Do you include the missing codecs in your ROCK VM?

I am copying the ffmpeg file just fine in the codecs folder but for whatever reason ROCK doesn’t use it.

I have resolved my issue and now my VM machine is fully functional with Codecs working.

I am copying the ffmpeg file from a Linux VM to ROCK VM and previously was connected as anonymous to the SMB share. Althougth the file was looking like copied, ROCK did not took it in account.

This time I connected to the SMB ROCK share using my Windows Host account details. I have copied the ffmpeg file and this time ROCK took it in account and I am all OK with all codecs installed!

glad you have solved the problem, and sharing your tips here:)

Not sure if you are still checking forum, but how have your experience been at this point? After going through initial installation, do you feel rest are compatible to plain ROCK?

I just ordered a 10th Gen i7NUC with 16GB RAM. I know its an overkill but got it for home automation HUB. So I am thinking to use ProxmoxVE and have it run ROCK and HA HUB.

Sorry for not being checking this forum for a while.

Yes, I’m still running ROCK on my PVE virtualized server, and everything went very well!


Thank you. Same experience here as well.

1 Like