ROCK Run OK for 8+ hours then stops showing "Roon Database and Settings Not Ready"

Roon Core Machine

NUCI3 as per exact recommended 11th Gen model
8GB RAM
256GB M2 SSD

Networking Gear & Setup Details

Ethernet

Connected Audio Devices

Number of Tracks in Library

12000

Description of Issue

Hello,

Second time in 24 hours ROCK has crashed on me causing audio to be unavailable when out and about.

I get this error, can someone from ROON support do some troubleshooting? Might be a proper issue/bug here as I am using the exact same combination of NUC and parts as recommended on the Rock guide and bought them all new from the links.

Ironic that I had zero issues with a docker roon image for a year on a synology NAS, was just chasing more speed…

I have similar experience:

I switched to ROCK OS for ROON Server on my NUC computer.
This is a separate dedicated audiophile modified HW: NUC 8i5BEK, with i5-8259U CPU 16GB RAM, 1TB SSD. Just passive cooling

After installing ROCK OS according to the instructions, everything works fine, except that ROCK arbitrarily disconnects from the data (TCP/IP protocol) network. ROCK can’t stand being connected for even 1/2 day! You always need to do a reboot of ROCK to connect again and stay functional for a while.
There is probably no error in the router settings. I have physically two different routers, ROCK is connected via cable. No matter what router I connect it to, it behaves the same.
Setting a static IP address instead of DHCP didn’t help either.
The previous installation of the ROON server on Windows did not have this problem here.

It is interesting that even if the ROCK disconnects, the ping to that IP address still works normally - see attachment below.
ROCK_ROON_ping_after_disconnection
ROCK_ROON_ping_after_disconnection
1105×525 52.9 KB
Sometimes it even opens his page in my browser and I can reboot the ROCK here. Sometimes not, but ping works.
However, ROCK/ROON Server cannot be used in this mode.
I have been working on setting up the Roon server to be stable and reliable for several months, no success yet (first on Windows now on the ROCK). It’s frustrating for me, believe me.

I can’t be the only one with this problem, I think.
Thanks in advance for your help. Maybe just a little is enough to make it all work reliably. Because that is what is expected from the server like ROON.
Thanks

I’m just adding here:
this is what the ROCK screen looks like when connected:

Here screen of ROCK if disconnected:

Wow this is interesting! Exactly the same issue.

My Rock sits happily like this screenshot for a while, then just goes offline / crashes showing not ready like yours.

This is often a sign of a failing drive or other component. Connect the nuc to a monitor or Tv and check if it gives any error messages on th output when this happens.

Brand new hardware so i’d hope not…! I was hoping the roon logs would be requested by support and checked for anything roon wise.

Plugged in a head, but just sitting on ROON screen not sure that would show any logs on the console. Lets see.

Ram and disks can still fail if new. It’s just one avenue to check. Another user had s similar issue and it was bad ram. It may well be something software side but it’s best to trouble shoot what you can before support pop up.

Agree. I’ve had USB drives die after a month!

I am well aware, i’m an IT consultant by trade. It’s pretty rare though.

I made it to 9.5 hours this time… last time was around 8

BIOS does not report any mistakes. When I ran there with Windows, there were no such problems like this, on the same HW.
@Snook You’re better off.
My ROCK stay connected for a maximum of 3 hours.