ROCK Server refuses to start

Nuc8i7BEH built with ROCK which worked fine for a couple of weeks and now the server refuses to start
I have rebooted and tried restart i have also tried renaming the RAAT Server file as suggested and had no success.
Your help would be much appreciated.@support

Is it similar to this problem?

Do have a usb drive or any other devices connected to the NUC? If so try removing them and seeing if it boots?

No there’s no usb connected. It’s made up of
1 x Intel NUC Bean Canyon NUC8i7BEH i7 8559U Barebone
1 x Kingston 250GB A2000 M2 NVMe SSD
1 x Crucial 8GB DDR4-2400 SODIMM Laptop Memory
With the music stored on a Qnap NAS

Yes it is the same issue. Well I get the same messages.

Hi @Paul_Goodlad,

Just to clarify here - you have accessed the ROCK Web UI and you’re seeing RoonServer failing to start? Can you provide a screenshot of this?

If you try to access your Roon logs by using these instructions, can you please upload a set to Dropbox / Google Drive /

Hi, attached screenshots but I’m struggling with the next part of the request. Can you supply an email so I can send the logs to you?

Add images

![image|666x500](upload://AgOj9lzHm0pvtzHzGnQu7xuzbsY.jpeg) ![image|666x500](upload://i1fLqDmVPvrZLznxkVolALAS5EZ.jpeg)

Add images

Hi @Paul_Goodlad,

Thanks for the screenshots. Regarding the logs, I have followed up via private message on where you can upload. Thanks!

Hi @Paul_Goodlad,

Thanks for sending those logs over. I took a look through them but unfortunately I’m not seeing much info here regarding the issue. Can you please confirm if you have a backup of your database made? My next suggestion would be to set the current database aside and try a new one:

  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reboot ROCK
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Restore your database from a backup

I had already tried the renaming of the Roon server file previously as saw it suggested on an old thread. However after trying it again lots of folders disappeared and the GUI said missing codecs again as it does on install. I reinstalled them but it still wouldn’t start and a subsequent reboot has brought up the missing codecs again. Aaaaaarrrrgggghhhh! I now only have Codecs, Machine Settings and Storage folders now. Think I might try to rebuild the entire NUC as I am getting very frustrated after the thing only working for a couple of weeks.

Hi @Paul_Goodlad,

Thanks for the update here. Since there’s still issues with ROCK starting after the fresh database, I concur, an OS reinstall at this point might be the best avenue forward. Do let me know how that goes or if you run into any issues, thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.