ROCK Server Won't Start on DH77DF

Greetings. I have a mini-itx motherboard with 80GB SSD. It is an older Intel DH77DF motherboard. i5 2.7GHz processor, 8GB ram. I am just trying to get away from vortexbox complexity. I installed ROCK, it loads and connects to router with ip address. I can access the ROCK GUI on the network. I downloaded and installed the codec ffmpeg. ROCK no longer complained about codec missing.

Roon Server will not start. I have searched other server won’t start posts. I have reinstalled, rebooted. Roon server will not start. There is no RAATServer folder so I cannot rename that to old. I don’t see any logs at all. My View files is set to show any hidden files.

I know I am not using current hardware. Just thought if it got this far, maybe I am overlooking something? Or it could be a waste of time as I am missing some older hardware drivers that prevents the server from starting?

ROCK version is 1.0, build 227, stable.

Appreciate any help, or abort advice, :slightly_smiling_face: and I’ll go back to vortexbox or maybe try some other headless alternative.

An update, the startup screen goes by fast so made video, did screen print. It appears to be an identity issue.

head: /sys/device/vendor no such file directory.

@SCompRacer I have ROCK running on an old laptop that has an i5 with maybe only 4GB of ram, can’t remember but it is low on specs and I’m able to upsample through the ROCK to 512 DSD and 256 DSD without problems.

By chance, did you try to install Roon on your laptop or phone on the same network and tried to connect to your Rock?

I can’t remember what Roon Server Software was, it’s been forever since I seen the screen in your first pic, I can update you later when I get home but that won’t been for anouth 4-5 hrs. I’m thinking it’s just installing the seperate app and connecting to your core (ROCK). Hopefully this helps or at least gives you a new idea to try.

“Roon Server Software” would be the Core server, which needs to be running for the remotes to connect to it. The “Operating System” is what allows the core to run on the NUC (or in your case the computer you are using).

I assume you tried hitting the “Start” button next to the Roon Server software entry on the GUI?

Beyond that you will need to either wait for the Support techs to chime in (if they will, not sure they will support using ROCK on unapproved hardware) or try in the tinkering area for help, as you are using ROCK in a way it was not design to you may have better luck over there.

1 Like

@bearFNF Thanks for the explanation, I couldn’t remember off hand, brain fart :rofl:

1 Like

Yes on the Start button. I’m thinking I may be in the unsupported category as you say and I initially guessed. I don’t expect them to fix it for me and I don’t have the smarts to fix it myself.

I’ll just go back to vortexbox until I get an answer or suggestion that may work.

I had roon on laptop and it was working until the 1.8 update. vortexbox is a chore to get to 2.5 beta where roon will work. I was just looking for the ROCK easy button.

When you click Start for Roon Server Software does anything additional land on the console?

With the OS booted you should be able to connect to the smb://rock/data share and poke around for any logs that are being generated. I’m assume, as long as the install completed correctly, that Roon Server is trying to start but something hardware may be incompatible causing that start to fail. The errors you’re seeing are certainly something that can prevent software from starting (script isn’t executing) but I don’t know exactly what’s happening at that point so I’ll let Roon @support take over from here.

Hello @SCompRacer ,

The only model NUCs that we have tested and support are in the following guide:

Any models outside this list, we have not tested and may not work correctly.

If you wish, you can try to install Ubuntu or Windows and have RoonServer running on the NUC, that way it still remains headless.

This boot screen looks similar to an SSD issue. You may want to try a different SSD, and if the behavior is still the same on that, there are deeper issues with the install, and a different OS is suggested.

I’ve also moved this post over to the #tinkering section since your ROCK model is not tested.

Also make sure you disable UEFI and Secure Boot, if these options are present in the BIOS setup. If these are changed, you need to reinstall ROCK from scratch.

1 Like

I received some advice to try Rufus instead of Etcher to create the USB boot drive. I have no idea why Etcher did not work (tried multiple times, multiple ROCK downloads) where Rufus did on the first USB boot drive I made. Roon ROCK is up and running. Roon ROCK, talk about plug and play…hopefully any future updates will allow ROCK to remain working on my unsupported hardware.

3 Likes

Good.

Who should be notified for considering adding a note to this guide?

1 Like

I have added a Rufus mention to the guide, @wklie !

2 Likes