ROCK shut down and can't restart, help ?!


Not sure anyone have similar experience ? I have my Intel NUC8i5BEH since May 2019 to running ROCK, 8 GB DDR4 2400 ram (ADATA) & 120 GB SSD (ADATA 2.5” SATA 6Gb/s SSD SU650) has install, original power supply connect and running well around 3 months, but my NUC shut down suddenly so contact Intel support for assistance, have tried Intel instruction to reset but my NUC still can’t power on finally. Intel have arranged a replacement within a week thru Fedex, then I setup my NUC again with the same 8 GB DDR4 ram and same 120 GB SSD again, the NUC keep running as well but it keep not more than 2 weeks then shut down again and can’t power on again even reset have done. Again, Intel have arranged the 2nd replacement within a week thru Fedex again, I setup my NUC again with the same 8 GB ram and 120 GB SSD again but its running for a week then dead again, I have contact Intel again and Intel response will arrange payment return for my case.

Not sure anyone have similar experience ? is it the problems caused by 8 GB ram or 120 GB SSD ? your comments and ideas is appreciate , Thanks

The problem is local. It could be the quality of your power, it could be down to insufficient ventilation. It may be the components you have re-used. That sort of serial unreliability is because of the environment you are in.

1 Like

Have you run tests on the ram just to check? Have you tried plugging in elsewhere in your home? Is the NUC in a well ventilated area? Are you using the same power supply?

I have had one NUC fail like yours, which intel replaced but three failing seems very odd or very unlucky.

1 Like

Really surprised they replaced it again without getting you to check your other components. Did they send new power supplies each time?

Intel has not replace a new power supply, I keep using the original set of power supply.

That might be your problem, it could be blowing your NUCs one after another.

Same problem here