ROCK timezone setting

I am having issues occasionally, when synchronizing my music library.
It seem to me that this is due to ROCK not setting a correct timezone, or perhaps just defaulting to some UTC time setting.

I just started up one of my ROCKs, an NUC6i5 in the shape of an Aleutia R50. This ROCK shares its media library with my MacBook Pro, which is loaded onto a portable LaCie 5Tb unit. When trying to synchronize the library over the network, the file dates on the external USB drive on the ROCK get a timestamp which is two hour behind my current time (CET, DST)… This causes robocopy to consider ALL files (almost 5TB) as old, and consequently try and replace them.

So, rather, I shut down the Aleutia ROCK and move its USB drive to the Windows computer where the current master of my media library resides. And on this machine, all file time stamps match up and there are no time differences at all.

Problem is, when I want to sync to my ROCK on a NUC8i3 with an internal 4Tb SSD, I simply can’t move the drive to a more coherent environment. I will have to tell ROBOCOPY to ignore older files, which kind of defeats the purpose of a synchronization.

Any suggestions on how to make a ROCK adapt to the current time setting?

I suspect then that this is the method you used originally to populate the drive and then you simply connected it to the ROCK which would then become the source of your troubles.

Note: Having a way to set the timezone on the ROCK wouldn’t help because different operating systems store different timestamps (local time versus UTC) in the filesystem. Swapping drives between machines running different OS’s might always lead to discrepancies regarding timestamps. Don’t do this if you need reliable timestamps!

Maybe you can tell ROBOCOPY to correct just the timestamps of the files while connected to the ROCK?

See also the following older thread:

Thanks for pointing out that thread @BlackJack, seems to be a similar quirk.
And i believe you are correct, the external drive was initialized and filled when it was attached to a Windows computer. What’s a bit confusing though, is the 2 hour difference.

Robocopy has a special parameter for allowing 1 hour differences, due to daylight savings time discrepancies but in this scenario it is not having any effect due to the 2 hour difference.

Still, i feel this would be quite common scenario for Roon users? Prepare your external drive using a Windows (or Mac i suppose) and fill it with your media. Then move it to your ROCK can, and never touch it again.

If you can’t find a method to sync the timestamps only, you have to sync the files completely or use the same method (connect to Windows PC and sync there) that you used initially.

May not work if a user wants to sync content based on timestamps but should work well for other use cases (no sync, sync on checksums).