ROCK: Transport error communicating to audio device

Hello all. Thank you for reading. I’m setting up Roon ROCK. I’m not expereinced with anything network related. I’m getting the error: “ Transport: Playback has failed due to an unexpected communication error communicating to audio device.” There is no sound.

I’m running ROCK (downloaded yesterday) on a NUC8i3BEH (with latest bios) into network into hifiberry digi+ running ROON (latest version, downloaded today). Into schiit Yggdrasil. Am I correct that the problem is between my hifiberry and my DAC?

What should I change?

Thanks!

I forgot to add: Im trying to play Tidal hifi, I’ve tried different albums with the same result.

As a start your device volumeon the Digi+ should be set to fixed. Are you using DSP as it active but can’t see you using it for anything. What is your signal path showing . If you go to now playing on remote and click.on the coloured for to the right it will show you.

Additional network configuration is also useful in helping diagnose any problems.

Thank you Simon Arnold!

The volume level: I think it is set on fixed this way?
The DSP: should I disable it? (Im disabling itnow, but the error stays)
Could you explain a bit more about where to find the signal path, where do I find the “now playing”? (Maybe I cant find it because of the playing never really starting?

Network: nuc cabled to fritzbox, hifiberry cabled to fritzbox.

Thanks!

Is this the “now playing” screen?

Click on the area where you see the song currently playing, that will bring up now playing. You’ll see a dot that’s either purple (lossless), blue (enhanced) or orange (Low quality). Click on that it brings up the signal chain like this.

It should show fixed volume not the blank like that. You can try resetting the device settings to defaults.

Also it might be that Alsa is muted on the pi. Check in Alsa mixer the state of the master and pcm outputs to see if they are muted or not. What distro of OS are you using on the PI?

Ah, I think this is the Now Playing screen?

I cant seem to find the colored dot…

Im unable to change the empty fixed volume, im goingto trie to set everything on restore to default.

Im using the latest roon OS on the pi. I’ll trie to find the alsa, is this in roon or somewhere else?

Sorry my bad, got my UI mixed up, thr the dot is next to the track playing on the bottom of the ui when your playing a track.

There is no Roon Os on the pi, do you mean the HifiBerry os image? If so I would ditch that and install Ropieee it’s much better and designed for Roon. HifiBerry image is not great.
Go here http://www.Ropieee.org

I think my dot is missing :slight_smile:

Ah, yes, I downloaded the image on the hifiberry page dedicated to roon, so I assumed it was an hifiberry-roon image. I will trie the Ropiee, thank you very much for all of your effort!!

Yeah because it cant play at all to the device by the looks of things. I dont think your configured correctly. I recommend you use a different os called Ropieee. Its the simplest one for the pi and the best for plug
and play. Follow the instructions fully on their site, it takes a while to fully install as it will download the full image of the internet after the inital boot so let it go through a few times until its done. Then you use the web interface to configure the soundcard to be the Digi+ reboot and your ready to add it to Roon.

Thanks, I will try this this week!

Thanks again!

Good morning / good day (to people in other timezones)

I’ve installed ropieee on my hifiberry. In Roon Remote the zone name doesn’t stick, when I fill it in. When playing music it keeps giving the same error.

I’ve re-installed the roon app on my iPad.

Does anybody know where to go from here?

I’ve ordered a SOTM bridge. See if that works.

Sounds like it could be faulty if that’s two os and issues. Make sure all the gpio pins are firmly in and you’ve not missed any just in case