ROCK will not install on NUC7

Dear Community and Support,

I am installing ROCK on a NUC7 but the installation brings following error messages, even after numerous retries:


16GB RAM Crucial SO-DDR4 2133 CL15 KIT (2x8GB) (single rank) CT2K8G4SFS8213
250GB SSD SAMSUNG 960 EVO M.2 PCIe 2280 MZ-V6E250BW

Roon ROCK worked flawlessly on this NUC in 2017, but I had to repurpose the NUC for Windows usage.
Now I want to have Roon ROCK back, but it won’t install on this same hardware.
I followed step by step the ROCK installation guide.
After above error message and a restart, Roon OS seems to work, web interface accessible, OS lets itself re-install. ffmpeg uploaded, but server will not start, not even after several re-boots.

What I tried:
BIOS defaulted and setup again.
SSD partitions deleted, formatted and tested, with bootable AOMEI tool
Tried two different pendrives for ROCK install image.
Several ‘etching’ of each pendrives with balena and rufus.

–>same result as above

What am I doing wrong?

Many thanks for your help.

CRC error usually means some data corruption occurred.
Redownload the image and burn it again is my advice.

Hello Paul,
Thanks, I forgot to mention that I downloaded the image several times. Same result.

I wish I could point you at the md5sums to verify it was downloaded correctly.
I am unable to.
So I can only point out it stating a CRC error.
Then “short read”
Both point to an incomplete image burn.

But I am wrong frequently as I learn too.
Hopefully someone will correct us.

I’ve had this issue when using certain image burners, and not with others. I can’t recall which one worked for Roon - I just have several lying around and retry with a different one when I hit a snag like this.

1 Like

I’ve found Etcher works well when burning Linux images.

Thanks for the replies.
I have evaluated creating the usb media with following 8 combinations:

Balena / Rufus
ROCK image zipped / unzipped
W10 / W7 PC

all of that variations end up with the same CRC errormessage above.
I re-downloaded the ROCK image several times, shows always the same size, same errormessage during installation.

Can I find an MD5 checksum for the image to check if my download is not corrupted?


The checksum I’ll leave to someone smarter than me. I can confirm I successfully used Etcher in the past, per a suggestion higher up. (Albeit on a previous version, as I’ve been updating happily through automatic updates for some time).


Short update: burnt the image with Win32 Diskimager - same error during RoonServer install (tar crc / short read).
The RoonOS on the other hand is always deployed and can be started. The Web UI is functional. I can even re-install the whole system from the UI. Only the Roon Server will not start. I cannot really understand this: when the OS is functional and is capable of re-installing the whole ROCK (my understaning), why is the RoonServer not repaired along the way?


looks like the SSD is broken in my NUC.
Thanks anyway for the valuable inputs.
Thread can be closed.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.