ROCK will not show up as network device in Windows 10 network

Hi all,

I just installed ROCK Version 1.0 (build 219) stable on an Intel NUC 8I3BEH Bean Canyon. Roon works and is now building the database.

I can access the ROCK homepage (so to say) via Chrome on my Lenovo Thinkpad Carbon X1 Windows 10 laptop by typing in the IP address.

However, I also want to add codecs to ROCK and this is not possible because ROCK does not show up among my network devices.

What can I do?


Add access to smb v1 shares in windows…

Here I’ve been here before…many times

@support please put this in the kB pages

Thanks, but I already tried that. No result. ROCK remains invisible in Windows 10. ROCK is visible on my iphone and ipad…

Meanwhile ROCK is visible after opening (almost) all network options in Windows. But I still cannot actually open ROCK. I get the message: No access to ROCK and an error code: 0x80070035.

Here’s a pretty definitive list of steps for that error

Thanks, but I still cannot approach ROCK. I can approach it from my old windows 7 computer without a problem.

The strange thing is that I can approach all other computers/NAS devices in my network with the exeption of ROCK.

Hi @Joost — Apologies for the delay here!

I just wanted to check in and see if you were able to get things up and running here. Were you able to connect to ROCK from your Windows device?

Hi Dylan,
Unfortunately I still cannot connect to ROCK. In the meanwhile a bought a new NUC which is still being assembled. Maybe this changes things. If not, I will let you know.

Am I the first with this problem, even after having tried all options as already suggested by Wizardfox and Ged?

Are you sure you performed all steps?
This sounds like the typical issue with Win 10 (Build 2004) where you NEED to ”allow insecure access to SMB shares”.
What happens if you try and map the Rock as a drive letter in Windows?
Use \\\Data as path, exchanging the ip address with the proper ip to your ROCK.

Theres a bug in Windows causing the need to adjust registry values, gpedit.msc won’t cut it.

Thanks. I will try that when I have my new NUC. I did allow the SMB shares.

Hi @joost,

Generally this issue stems from problems with Windows settings, as suggested above. Definitely let us know how things go with the new device and whether or not the IP address path works for you.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.