ROCK with Synology NAS: Could not connect to share: Unauthorized

Core Machine (Operating system/System info/Roon build number)

ROCK on NUC8i5 running latest download from ROON website
Music files in shared folder on NAS: Synology DS414j
smb share enabled

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ROCK and NAS connected via Ethernet to an Airport Extreme

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Numerous Sonos boxes plus 2 head amps connected to IMac

Description Of Issue

ROCK is a new setup.
Prior to this was running latest version of core on iMac.
IMac Core could connect to the NAS shares without issues.

ROCK will not connect to the NAS.
When I try to add folder I get the message: Could not connect to share: Unauthorized.

Some other points:

  • NAS Folders are shared
  • Shares are via smb
  • username / password when trying to connect to NAS are correct.
  • shares can be accessed by all other computers in the house (2 x Mac and 1 x Windows)
  • have tried the various options for the changing share path such as IP address / adding .local etc as per other posts in this forum.
  • whole system: ROCK / NAS / Router / Mac have been rebooted a bunch of times.

Anybody have any ideas? As I say, its only ROCK that will not connect to the share.
I can revert back to iMac as the core and enter the same share details and connect to the NAS without any issues.


I think I’m duplicating what you’ve already done by the sound of things, but I use \\ip.address\share_name for my Synology from Rock.
No Workgroup name.

(PS You have read the KB article?)

1 Like

Thanks for the reply Brian.
I have fixed it so this thread can be closed. And yes, the KB article had the solution.
Stupid on my behalf - had a special character in my password.
ROCK does not like that. Was not an issue when using OSX as core.
So, happy days.
@Support you can close this.

Indeed. Pleased you’ve solved things. Now enjoy the music.

1 Like

Not as pleased as I am dude.
I had the NUC assembled and flashed with BIOS and ROCK in 20 mins today.
Then spent 7 hours scratching a hole in my head all because of an @ symbol.
Cheers :+1:

1 Like

Hello @ogdens_sliced, glad you got some help here! Please let me know if you have any further issues, we’re happy to help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.