ROCK won’t recognize ffmpeg

Continued from

How can I do that on Linux?

I have the same problem, no matter from where I copy the ffmpeg with Linux, Rock won’t recognize it. What can I do?

What Oliver did was go to the file as shown above, right click on it, and select properties, then the security tab. Then you enable the permissions as he’s done.

I tried that, but Nemo and Nautilus show no permissions at all

We probably all have different file structures/ownerships, so I don’t know what Nemo and Nautilus are. Can you share a screenshot like Oliver did?
If you are using a pure Linux installation, that’s over my head but some other user will probably know how.


I connected the share with the -t cifs option, works now! Maybe put that in the install guide for us linux users?

Glad to hear you figured it out.
I don’t know why it isn’t put in there to start with? It must be some sort of commercial rights restriction?

licensing fees, apparently

One has to pay patent licensing fees to ship code that implements the AAC patents. That’s what ffmpeg provides. On Window/Mac, the codecs are built in so we don’t ship them. On Linux, most popular distributions have it already, and they’ve paid those fees.

For Nucleus, we pay the fees, since it is a commercial product. For ROCK, because we don’t charge for it, we can’t build it into the price. It’s a relatively small fee, but we have had quite a few ROCK downloads.

This used to be the case for MP3 as well, but those patents expired recently.

Thanks for the explanation Danny. That’s very reasonable.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.