rooDial technical integration discusions

Ogs,
rooUPnP will be out during next week.
You have to enable Squeezebox support in Settings–>Setup. Then audio will be transferred via LMS-Protocol to rooUPnP and from there to the UPnP player. There will be some settings for the individual UPnP players to adapt to their capabilities.

Bild1

I will start with a licence free of charge for a certain test period to give everybody the chance to see if it works with his player(s). During this perid I will set up a list with supported UPnP devices based on the community’s feedback.
Stay tuned :slight_smile:

I am using 1.3.0 beta

This will not be workable on a RPi Zero as its doesn’t support the right architecture for Roon Bridge. You will only be able to support this on a RPi 3B min as I think BT is not available on the RPi 2 models

1 Like

Thinking about this probably means you have to differentiate your builds to exclude roon bridge ona detected zero install. Or have roon bridge as an after setup optional install on 3b and better pi’s.

1 Like

No, I will check this at runtime. rooUPnP als also rooPlay (this us roon bridge) will check for ethernet. If not available they just won’t be started. I only will support ONE imagefile. Otherwise things will come too complicated for the user.

1 Like

rooUPnP is out

rooUPnP: Finally a Roon Extension for UPnP Streamers - Roon Labs Community

My Pi completely stopped working with 1.2 installed. Nothing would provoke it to boot. It was working fine, then today it just stopped. I knew the Pi was fine because when I plugged it into the PC, it was recognised.
I then installed 1.3 on a separate SD card and it installs and runs fine. It appears my SD card is corrupted, so am I to believe this means my licence no longer can be revoked and I can no longer use rooDial?

You can, send me your license number please and I will revoke it for you.

2 Likes

Very strangely it looks to have already resolved itself. I left it for a few minutes and somehow the licence is now active in this version! Working perfectly! :slight_smile:

I’ll keep an eye on it but for now it’s good - very happy again
Thanks for the offer of help though!

Jay_Kay,
I got reports like that before. I guess I changed a setting at sellcodes that now allows for multiple registrations from the same Pi.
Maybe I can omit revoking completely in next release.

2 Likes

Yeah I understand that from your point of view, it’s a way to protect your IP. The key issue is that microSD cards seem to have wildly varying reliability.

I guess while the product is still niche, it’s easy for you to manage exceptions, but if your userbase grows, it will become a decision based on how much this inconveniences you to rectify individually. I’m glad you’re so responsive in this thread but I’m sure your time is worth more spent on fixing more complex issues and creating new products

Either way, thanks for responding so quickly :+1:t3:

1 Like

@DrCWO Seems to be a problem pairing on my PiZW with 1.3.2 beta but I managed to get paired with the same hardware using 1.3.0 stable release.

just an FYI

Situation:

  • I have one working setup on RPI4B , RooDial V1.30 with Microsoft surface dial (lot2044)
  • Bought 2 additional RPI4B + 2 additional Microsoft surface dails but cannot get last step, bluetooth pairing,working!
  • Have bought 4 licences RooDail

Did a lot of experiments yesterday to tackle the problem
"Situation B" was requested todo by @DrCWO but didn’t succeed.

Summary: (my observations)
1 V1.31 after “reset to factory defaults” WIFI RPI4 is lost, never comes back online!
2 Repeatablity is sometimes low when I repeat exact same steps on fresh RPI4 + fresh SD-card image.(reaction is different)
3 Microsoft surface dail (lot 2044) versus (lot2048) seems NOT a lead to the problem!
4 Bluetooth pairing step put status after few seconds to “sleeping” in Roon (Microsoft dial never pairs)
5 Checked the two non pairing Microsoft surface dials with Windows 10 they pair and work!! (than unpaired them in W10)
6 My third Microsoft surface dail died during the experiments.( get NOT getting it to pairing mode anymore)
7 After ALL experiments I went back to a fresh image of V1.30 and succesfully to connected again to my one and only working setup!

Because I have one working set-up I took it as starting point.(= Situation A)

"Situation A" : RPI4B + RooDial V1.30 with WORKING Micrsoft surface dail (lot 2044) **

  • This set up is the one and only setup that works!!
  • Visit http://IP_adress_RPI4
  • “Reset to Factory defaults” (I didn’t expect this option to appear because of V1.30)
  • Start Roon ==> enable RooDial
  • Took second MS-Dail (lot2048) put it to pairing mode
  • Pairing continues forever NO connect!
  • Removed battery MS-dail shortly to stop pairing.
  • Visit http://IP_adress_RPI4
  • “Reset to Factory defaults”
  • Start Roon ==> enable RooDial
  • Took my old working MS-Dail (lot2044) put it to pairing mode
  • Pairing succeeded after few second " paired"
  • Visit http://IP_adress_RPI4
  • “Reset to Factory defaults”
  • Start Roon ==> enable RooDial
  • Took my second MS-Dail (lot2048) put it to pairing mode
  • Pairing continues forever NO connect!

"Situation B": RPI4B + RooDial V1.31 on fresh SD-Card image

  • Connected to Rooextend network → with key:1234567890
  • Visit http://10.0.0.5 → selected my “Audionet” network
  • Start Roon ==> enable RooDial
  • Took my old working MS-Dail (lot2044) put it to pairing mode
  • Status in ROON changed from “unpaired” → “Sleeping” within a few seconds??? (pairing doesn’t succeed) ** point4 summary**
  • Visit http://IP_adress_RPI4
  • “Reset to Factory defaults”
  • The RPI4 disappear in my WIFI network and NEVER comes online again!! “point 1 summary”
  • RPI4 blinks in one second ritme, non visible in network → ENDs this experiment

Repeated steps of “Situation B” with fresh SDcard image, SAME results V1.31 not working for me! (it disconnected from WIFI after “Reset to factory defaults”)

"Situation C": RPI4B + RooDial V1.31 on fresh SD-Card image

  • Connect LAN cable to RPI4 (difference with previous Situation B)
  • Start Roon ==> enable RooDial
  • Took my second MS-Dail (lot 2048) put it to pairing mode
  • Status in ROON changed from “unpaired” → “paired” (for 1st time MS-Dail lot 2048 works!!) “point 3 summary”

For repeatibility I repeated “Situation C” with a fresh SD-card image:

"Situation D": RPI4B + RooDial V1.31 on fresh SD-Card image

  • Connect LAN cable to RPI4
  • Start Roon ==> enable RooDial
  • Took my second MS-Dail (lot 2048) put it to pairing mode
  • Status in ROON stays on 'unpaired" and pairing continues WITHOUT success. “point 2 summary”

"Situation C" and “Situation D” should have given SAME results but it didn’t (I’am Lost)

"Situation E" : RPI zero W, Roodial V1.30 + Microsoft surface dial (lot 2048)

  • I was not able to get my WIFI connected to this “RPI zero W” so gave it away to a friend.
  • At his place :
    • Connecting to his WIFI worked.
    • Pairing in ROON worked (with Microsoft surface dail (lot 2048 !!) “point 3 summary”
    • Working setup at his place.

Finally I went back to V1.30 with fresh SD-card image and first working Microsoft surface dial and that is still the ONLY one i get to work.
Hope this helps debugging the issue.

Wim,
Before I continue writing. THANK YOU for your very deep diving. I am sure the issue can be solved and your input is really helpful to fix the issue.

I like to support you but I ask you politely to delete your last post on the main tread and repost it here: rooDial technical integration discusions - Audio Products - Roon Labs Community
My plan was to have the more general questions in the main thread and technical in depth discussions here.The idea was not to mess the main thread (for non-teccies) with things that are annoying to them. Hope you understand and thanks for moving the post.

Now to your observations.

  • It works for more than 100 customers most with Pi Zero W so I like to find out what went wrong with you.
  1. The idea to “reset to factory defaults” is tom bring the Pi Zero W is in the same state as being freshly flashed but for convienience I keep the entered license. So for shure WiFi and the Dial get unpaired after pressing this button.
  2. Cannot comment on that, my believe it do the same things and same things happen.
  3. That the LOT number is not the reason makes me happy, thanks for the information.
  4. I had the situation before with an other customer. Instead of Pairing the extension shows “Sleeping” in the status. I had a Zoom session with him digging into his Pi4! The result was, that I saw an error code in the log saying that there is a power issue with Bluetooth in the Pi. The cusomer ordered a new Pi4 now and hopefully this issue is solved. First I also thought this was an issue with the Dial. But he replaced it with no effect. Two weeks ago I ordered a Pi4 for a friend of mine. Same issue. I retured the unit and got a new one that worked. Seems to me there are some Pi4s around having the same issue. First I thought it is the power supply but it was not.
  5. Expected that.
  6. This was reported by a lot of customers! They retured the Dial and got an new one. This is really a hardware issue in the Dials.
  7. Regarding rooDial there not a line of code difference between v1.3.0 and v1.3.1. So having a combination of Pi and Dail that works with v1.3.0 I have no idea why this combination should not work with v1.3.1.

The differnt situations you described seem really odd for me and I like to know what happend. So I offer to have a teams or zoom session where I can access the linux of the Dial directly and see what happens there. Please let me know in which timezone you live to make an appointment.

What I like to ask you. Do you have a second powersupply at hand that can be exchanged? I run an Raspberry supply with 3A and never got any issues.

Best
Charly

Wim, I tested with a second Pi4 right now and run in trouble, maybe the same issue you reported. I will keep you informed. Sorry for the trouble…

1 Like

Hi Wim,
my situation is that I have a Pi4 here, that cannot be paired with bluetooth. I updated the boot eeprom but no change. The situation is unstable, so sometimes I see an error regarding bluetooth power, sometimes this works and it seems to pair but after pairing the connection is lost immediately.
I work on this issue and will report further advances here in this tread. Again thanks for your helpful input.

1 Like

Wim,
I like to get back to you regarding pairing with Pi4.
The issue are different revisions of the PI4s. I developed and tested all my things on Pi4 revision b03111. Now I got a Pi4 revision b03114 and pairing did work no more! I can’t tell about all the other revisons ( Raspberry Pi revision codes - Raspberry Pi Documentation). It seams they changed something regarding the timing between CPU and BT-controller.
In my lab I made it run for revision b03114 and will release it soon. In the new release there will be a readout of the revision number in http://rooExtend.local/service.html. Hope this will make things better in future.
I’l let you know…

Update: Today I put a fresh image (v1.30) in my RPI3B just to see what will happen. Connected it to LAN and started RPI3B, surprisingly RooDial pop-up in ROON. I enabled it and could easily get my 2nd Microsoft dial, that never connected before, connect via BT! Unfortunately, but ok the image was never suppose to work on RPI3B, rotating the dial or pushing the buttom ! of the dial is NOT reflected on the screen in ROON. My feeling is it has more todo with BT v4.* used in PI zero W & RPI3B versus BT v5.0BLE used in RPI4.

Please take out batteries, reinsert and report. In your screenshot I see “connected”. If you take out batteries you should see “Sleeping”. After reinsertion “connected”. My guess twisting and pressing will be reflected then. Please let me know.

My guess it It should work on 3B. I own one so I could not test…