rooExtend – The easy start with Roon Extensions

This is correct, enabling and pairing cannot be transferred.

Yes, no more SD-Card programming no more extra steps. All will be one automatically in the background :+1:

I tried to restore all, WiFi and Settings but seemed not to work sufficiently. After being reconnecting to Wi Fi pease take a look at the USB-Stick. Delete the file rooExtend_wifi.json plug the USB-stick and try to reboot. Hopefully it should connect by WiFi and restore the settings incl. licenses now.

It will also update the wireless PIs. I use the standard Linux update mechanism with cryptographical signed apt-packages. Gold standard to avoid any side loading of malware :slight_smile:

I’l put this on my list, good point!
Best DrCWO

I’m through the updates. What I believe happened is that the update process ingested (and deleted) the settings file, applied WiFi settings, but did not apply anything else. Reboots didn’t help.

This is great.

Thanks!

1 Like

@DrCWO I assume we DON’T HAVE TO do the USB backup - this is a PITA on a Pi Zero W2 and if you have a few rooExtend devices (I have 5 I think) takes up a lot of additional USB sticks as each one has to have its own stick.

Thanks for the update. Following the instructions all went smoothly except adding the extensions for device control. For some reason the Meridian serial control does not show on the pi that I have rooExtend installed on. It does still show on my other pi. Any simple way to update?


Right, you don‘t have to.

The first bug was found!
Connecting a USB DAC that has no ADC crashes rooExtend. Pleas keep your rooExtend Raspberrys on I will provide an update soon.

Best DrCWO

Please ask @Jan_Koudijs. If this is a docker Roon Extension it seems to be not yet available for ARMv8. If not there‘s a way but I don‘t remember.

Edit: Look here

:exclamation::exclamation: Update v3.0.3 is out :exclamation::exclamation:

  • Fixed the bug with the crash using a UDB DAC without ADC.
  • Added a new Button at the rooExtend Service Page to manually look for updates.

The update will be installed automatically between 2AM and 4AM of your local time.
You have to leave your rooExtend Raspberry powered on during this time period to get the update.
First productive test of OTA update :sweat_smile: cross fingers :pray:

After successful update you will see v3.0.3 in the License Manager Roon Extension.

Best DrCWO

4 Likes

ha ha I am just burning 3.0.2. to a memory stick now!!
Off I go to get 3.0.2 then :+1:

Currently it is still showing 3.0.2 in the Google drive

This release will stay!
Upgrades from now on via OTA at night only.

So burn the 3.0.2 Rease from Google Drive, sleep one night and you’ll be upgraded to v3.0.3. :+1:

Best DrCWO

1 Like

Thank you Doctor it was booting as I posted the message, and having a look now :+1:

Well, after rebooting the Pi (do I really have to unplug it every time?) the new release appeared for only a few seconds in the Roon settings before disappearing, so I had to be quick and I had to be persistent. I finally got it running but there is some strange behaviour like no reponse in the library search and no response if I tap on a playlist.
Interestingly, if I play a radio station and then stop, the watch will still follow what’s playing on that station after I have stopped.
Also I notice that rooControl is enabled in the settings as well as rooWatch. Previously only rooWatch. Is this intended?

  • Are you talking about rooExtend v3.0.2?
  • Do you have a DAC connected?

If yes this is the bug that will be solved by v3.0.3. Wait for next night to get the update to v3.0.3.

@Klaus_Engel
I believe he is talking about the rooWatch App. Any idea what goes wrong?

rooControl is for free, you can disable it in the License Manager.

Best DrCWO

Yes

No

Yes rooWatch app

Ok thanks

Thanks Doc both my Pi’s have 3.0.2 in and running and I will wait for 3.0.3 tomorrow.
I am guessing the BT information is in there as well.
I noticed my once solid study BT device dropped off twice this afternoon and that made me remember that I had the Zexmte Dual class 5.1 device that I bought to test with v3 when it came out.
I have put that in and rebooted and it dropped off once again (after about 20 mins), and as soon as stopped that being locked to a single device it came back on.
I will keep an eye on that but it will be good to know what BT dongle/device it is actually using.

Great to have Roon Extension manager installed as I have now configured that for the living room RooExtend box and unplugged the DietPi that was only used for Sharoon at this point.
Also noticed that all the extensions seem to be rock solid now, without them disappearing and coming back all the time so that is also nice to see

1 Like

@Klaus_Engel
I disabled rooControl from the settings, killed the app and rebooted the watch. Same response. Deleted and re-installed the rooWatch app. Now my browse list is completely empty.
Roon suggested entering the IP address in the app settings. I cannot find the setting.
Here are a couple of pics:


Swipe down to get to the “Options” screen. All down this page you can enter the IP number.

You get the browse list of you double tap. I saw an empty screen also at the first try. But doing it again the menu is filled…

Found and entered the IP address. The Browse list is now available and I could display the list of albums (only as far as B because the Load More function did not work). The My Live Radio function works fine but a search for artists produces no results. I can get into the playlists but they will not play. All very strange.

Hi.

I’m trying to move a Nuimo dial over from a modified Nuimo Hub to a Pi 4 running rooExtend 3.0.2.

I’ve revoked the license from the Nuimo Hub and have successfully applied it on the Pi. rooExtend accepted the license.

Regardless of what I do, I can’t get the Nuimo extension to show up even with “Hide Unlicensed Extensions” set to false. I tried another rooExtend box and I similarly can’t get the Nuimo extension to show up.

I’ve tried everything I can think of including resetting the Pi to factory using the web interface. I’m out of ideas. Is there a chance this is an issue with 3.0.2?

In the license manager there is a selection Dial or Nuimo. Set it to Nuimo and the Extendion will show up :grinning:

Oh boy. Sorry for taking your time on this. Thanks for the quick and helpful response. That was, of course, my issue.

Since Dial and Nuimo support are mutually exclusive, it might be a usability improvement to disallow applying Dial and Nuimo licenses concurrently. You could, for example, show an error when a user attempts to set a Nuimo license while a Dial license is applied (“Dial and Nuimo are mutually exclusive. Revoke your Dial license before applying a Nuimo license”) and vice versa. That would allow you to remove the toggle switch that I once knew existed but managed to forget :slight_smile:

1 Like