rooExtend – The easy start with Roon Extensions

Update up and running. Works just fine.
Thank you!

1 Like

Hello DrCWO,
I have a problem with Google Drive who refused me to reach the folder of the new upgrade of rooExtend.
Any advice to solve this ?
Thanks a lot.

Right now I installed a fresh firefox without any cached credentials.
I can access both links I posted above without any issues :thinking:

Did you live behind the Chinese firewall :wink:

No Idea how I can help here, sorry
Best DrCWO

update worked for me, but i still needed to give in my serials manually, might be my fault.

My Problems with the nuimo persists. How can i now see what BT Interface is used. I found a hci0 in the service info, is this the inbuild BT-Radio or might this be the zexmte? What could i do to make this thing work? Even near the Pi the BT-Symbol on the nuimo blinks without end, only seldom the ready sign goes up and then moving 50cm with the nuimo, again blinking Bluetooth sign without connecting…

Maybe i should look at this nuimo Firmware thing, maybe this helps. But first i have to know what to search for in service info to see is the stick gets used. After that and if the stick works and my problems persist further i might look what Firmware my nuimo is on.

anyhow, seems like i have corrupted my SD card, rooextend didn’t start anymore, cannot go to rooextend.local, so i now burning a new sd-card and will test further…

I’m living on the west side of the chinese wall, in Paris France.
I’m using chrome or safari, and the both refused the access to your download site.

At the end of service page the page you should see this:

You can see that hci0 runs on Bus: USB up running. This is the antenna.
Also hci1 runs on BUS: UART down. This is the built in BT adapter.

Below you see that phy0 (wlan) and hci1 (bt) is without power (blocked), only hci0 is unblocked.
This means it is used. The others are switched off.

Did you get the same output?

Did not know that France also has a firewall now (sorry I’m kidding) :wink:
Installed a fresh Chrome and also no issue there.
Did you run Pi-Hole or any other DNS service that did not give you the right IP?

Try to ping from your console. You should get a response from
You also can try in the browser to access

Best DrCWO

Thanks Doc but I solved the problem with disconnecting my google account using Chrome, now I got access to your folders and successed to download that I was looking for.
I’ll make a try of your new version of rooExtend.
Congrats for the job.

1 Like

Thanks, there was no hci1 in my first try but with the new card i got similar output. OK, this looks good so far but after just pasting in my nuimo serial again and saving the extensions vanished from roon, waited a minute or so, nothing, so i restarted the pi.

Now several minutes later, no sign of rooextend not in roon also not on rooextend.local.

I Stop everything now and connect a small monitor to the pi to see whats going on while booting or changing settings in roon extensions.
so long…

Congrats, Herr Doktor. :partying_face:

Happy to report that the updates were entirely uneventful, on both my Pi 3 and 4.

1 Like

Starting rooExtend stalls at this point:

So far so good. However, the display on the TV is now a bit strange. Instead of a full image (as before) I now have a smaller image that doesn’t fill the screen. Behind is the blurry display of the image in the outer border. hmm…

Same Chromium settings as before. Seems DietPi handles that different. Wonder why??
Ever tried to reboot with the Screen on an connected?

Yes. But the same behaviour.

I installed the updates on one of my rooextend boxes and unfortunately there seems to be an issue with the DAC connected to USB. I have three others also connected to usb so I’m holding off on trying those.

As soon as the USB DAC is attached the extension dies and also am unable to pull up the local IP to check status. Roon bridge is working as Roon can see the DAC. As soon as I unplug the DAC, the extensions comes back online.

This DAC did work previously. Here’s the log:

Nov 24 09:34:26 rooExtend rooExtend[7196]: Audio device:  Holo Audio Holo Audio UAC2.0 Gen2.1 Enhanc Card: 1
Nov 24 09:34:26 rooExtend rooExtend[7196]: Caught exception: TypeError: Cannot read properties of undefined (reading 'found32')
Nov 24 09:34:26 rooExtend rooExtend[7196]: Exception origin: uncaughtException

Currently no idea :thinking:

And I’m missing the reeboot command. But that doesn’t matter, I’m back to V 2.3.2 now.

Hello and congratulations on your release!

I’m in the process of upgrading my extend instances. The process is raising some questions for me.

I have two wired and two wireless Pi 4’s. I’ve updated the wired. I’ve used a USB stick to persist and restore settings. In each case, I had to manually re-enable the license manager, manually re-enable the rooDial extension, and then re-pair the dial.

The license carried across, but the enabled state and the dial pairing did not. Is this expected for this 2.3.2 → 3.0.2 update? Does the auto update implemented in 3.x improve upon this so that there won’t be use interaction required?

I’m now trying to update my wireless instances and I’m not sure what to expect. I saved settings, flashed, inserted the USB stick, booted. I waited long enough for the new instance to import settings, then pulled the USB stick. I was interested in seeing if WiFi settings would be carried across. Based on what I see, I think what happened is that WiFi settings were applied but the rest of my settings (including my dial license) were lost. I was able to re-apply the dial license and re-pair the dial.

I’m hoping the 3.0.x auto update works for these wireless devices as well as for the wired. I don’t understand if your update model is able to address drivers and OS or if it’s just app bits. I’m sure we’ll understand soon :slight_smile:

I do have a feature request. A couple of my devices are in locations that cause the status lights to visible, so I turn them off in settings. The current setting indicates that they’ll be restored to “on” when the Pi reboots. If your update model is going to be doing reboots, is it possible for you to either make the setting permanent or add a “restore previous setting” option?

Thanks for all the work you put into this!

This is correct, enabling and pairing cannot be transferred.

Yes, no more SD-Card programming no more extra steps. All will be one automatically in the background :+1:

I tried to restore all, WiFi and Settings but seemed not to work sufficiently. After being reconnecting to Wi Fi pease take a look at the USB-Stick. Delete the file rooExtend_wifi.json plug the USB-stick and try to reboot. Hopefully it should connect by WiFi and restore the settings incl. licenses now.

It will also update the wireless PIs. I use the standard Linux update mechanism with cryptographical signed apt-packages. Gold standard to avoid any side loading of malware :slight_smile:

I’l put this on my list, good point!
Best DrCWO

I’m through the updates. What I believe happened is that the update process ingested (and deleted) the settings file, applied WiFi settings, but did not apply anything else. Reboots didn’t help.

This is great.


1 Like