Roon 1.3 (269) on QNAP NAS, Remote never manages to connect to Core [Resolved]

@support,

The problem started yesterday night, when suddenly the Remote lost connection to the core and since then was never able to re-establish the connection.
I do not get an error saying that no core was found, but forever the message ‘trying to connect to core … takes longer than usual’.

Is this related to the 1.3 (269), (automatic) update? It seems so and if so, is there any way to turn off automatic updates? As I have seen many who run Roon on a QNAP NAS have reported problems.

Anyhow, the log files are saved here: https://www.dropbox.com/sh/qagkl326nxc5wkx/AAAOq7sj9CFpGwk8aRLyXOMTa?dl=0

The question is basically: why are the roon processes running on the NAS not responding? It seems they are either busy or just hang.
I monitored the processes (screenshot saved at above address) and the following turned out:

  • RoonAppliance is the only process consuming resources, almost always at the level of 25% (1 core of the quadcore processer I assume) of processing power. I also observed that the consumed RAM is steadily increasing, until I saw the process actually crashing and restarting at the moment it had around 1.2GB of RAM allocated.
  • RoonServer consume 0% and RAATServer consume almost 0 (0.12%) CPU usage

I also noticed that my last backup is from 19 October, even though automatic backups are/ were scheduled for every second day. Is the update to 1.3b269 known for ignoring scheduled backup settings?

Therefore I rather find a solution to this than having to go back and redo the work of the last week.

Any suggestions welcome!

Thank you,
Christian

Hi @Never_Ever ---- Thank you for the report and sharing your feedback with us!

Moving forward, I can confirm that I have received the provided materials (logs + screenshots, thanks!) and furthermore would kindly like to ask you to please provide the following information to help aide in our understanding of this behavior you’re experiencing. Please see below.

  • Please provide the make and model of the remote(s) having the issue.

    • Are there any remote device NOT having this issue?
  • Please provide the make and model of the NAS you are implementing.

  • Please describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing in your setup. I want to have a clear understanding of how your devices are communicating and all the tools involved with making these connections possible.

  • Does manually entering the IP address of the core ever re-establish the connection?

  • Please verify if one or both of the following tests allows the remote device to successfully communicate with the core machine:

TEST #1:

  1. Shut down your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Roon should be on the “Searching For Core” screen
  4. Start up the Core

TEST #2:

  1. Start up your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Kill the Roon app
    (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
  4. Restart Roon on on your Remote

-Eric

Dear Eric,

honestly, I don’t think that the remotes are the problem. They all worked fine until that moment where the connection was lost and since then I can’t reconnect anymore (yet it is at least able to identify a running core).

I use remotes on 2 platforms from 3 devices:

  • Desktop computer, running Apple macOS, v10.12.6
  • 2 mobile devices, running Apple iOS on iPhone and iPad (both v10.2.1)

All the other settings are the same as from my first customer support request, the only difference being in the build version of the Roon core that went up from 262 to 269:

  1. Qnap NAS TS-453A running QTS 4.3.3 (build 0262 2017/07/27) with Roon Core (v1.3, build 269 V2017-02-02)
  2. Network: TP-Link Archer C1200 Gigabit Ethernet Router, desktop hardwired to the router, mobile devices via WiFi
  3. Audio: 1st option: output via AirPlay to Denon AVR 2313 receiver (hardwired to router), 2nd option via HDMI directly from QNAP NAS

I know that these repetitive questions have to be asked again and again about configuration settings etc. So, as a feature request/ suggestion to you:
Why not add a section to each user’s profile which has to be filled out with the configuration information before being able to contact support? I guess that would make your life a bit easier … Just my 2 cents

Honestly, I wouldn’t have contacted you if the solution would be that easy as the 2 test cases you describe. I would have felt idiotic in not having tried out the obvious. Having worked in system administration and customer support my self, I usually try all that is within my own possibilities to find a solution before resolving to contacting support.

Anyhow, I guess I have to bite the bullet again and do a fresh install of the Roon Server and then try to start with the latest backup from the automatic scheduled backup. Hope that will work …

Additionally, from my side the following are still open questions:

  • what is the RoonAppliance process exactly doing? Is this the database backend process?
  • The CPU usage (constantly at 25% = 1 out of 4 cores for days) and RAM consumption (growing until it reaches a certain amount, mostly around >1.3 GB of RAM, then crashing and the cycle starts again) patterns that are visible from the screenshots I had attached to my original request: could that be an indication that the database is corrupted or is it a hint to something else?

Thank you,
Christian

Dear Eric,

just to let you know that I’ve “solved” the issue by making a fresh install and going back to the latest backup available to me.

My best guess is now that one of the albums I had added caused the crash and subsequently a corrupted database.
In case I come across the exact album again that caused this I will give you access to those files for you test/ replicate this behavior.

Best,
Christian

Thanks for the update @Never_Ever, appreciated!

Happy listening!
-Eric

No problem. I think I found the file that caused the problems. I’ve uploaded it to Dropbox and have a look. In particular the content of the ‘Title’ tag.

I can play the file in Apple Finder or on MS Windows in MediaMonkey, but even MediaMonkey fails to open the ‘Properties’ window with a message ‘OS function call failed’, yet the ‘title’ tag content is displayed in the library list view of MediaMonkey. That is how I spotted it. And I also remember that it was around this album when the connection to the core was lost and the whole problem started.

Thanks @Never_Ever, can you provide me with a shared dropbox link containing the media in a PM addressed to me?

-Eric

This topic was automatically closed after 30 hours. New replies are no longer allowed.