Roon 1.3 and HQplayer: No sound after update [Fixed in B194+]


Hi, please help. Blue bars moves on play. But no sound. Bottom progress bar does not move stuck at 00.00.
Frustrating. Both Roon and Hqplayer settings unchanged from before update. Thanks.

That’s strange–HQPlayer is working fine for us here.

When it’s failing, what does your signal path look like?

Just after update. Signal path, meaning?

Sorry if I was unclear. I was asking for a screenshot of the Signal Path screen in Roon during the failure, so I can try to replicate the same thing here.

Same problem here with all the same symptoms – also, signal path looks normal from the track to through Roon to HQPlayer.

Late-2012 i7 Mac Mini 16GB RAM, 480GB SSD, Mac OS 10.11.5.

Thanks for any help. Music was playing fine with the last build of 1.2, now with 1.3 nothing.

Steve Z

Thanks for the prompt response.

Subscribed, as i also use HQPlayer as the playback with Roon.

Currently letting my 1.3 update finish its housekeeping before playing back for first time.

But i did notice that DSP engine was enabled for hqplayer.

I’ve disabled DSP engine.

Here is a screen shot with signal path for a song from TIDAL that gives all appearance of playing but progress bar remains at 0:00 and no audio output:

Same behavior with local content or tracks from my NAS.


Steve Z

Thanks guys, fiddled around and was able to reproduce the problem. This will be fixed in the next build. Sorry for the inconvenience.

Same signal path as you and same outcome. No output. Hope it gets fixed soon.

Tried it both with engine enabled and disabled. Neither one worked.

Are you on mac as well for hqplayer?

I don’t know what the root caused is, but thankfully the fix is eminent.

Yes. I’m running Roon core and HQP on the same Mac.

I can explain a little bit more:

At the last minute–Friday of last week–we had to add some IPv6 networking support to Roon to satisfy one of Apple’s requirements and pass their app approval process. It involved some low-level networking changes. One of them had an unexpected consequence that broke HQPlayer streaming under some circumstances.

Since this change happened really late in the development process–after most of the QA work was done–there wasn’t time to begin testing everything again from scratch. Our main HQPlayer test setup is on Windows–which wasn’t affected by this bug, so this didn’t come up in a quick “make sure HQPlayer still works” test, since the problem was platform specific.

Major releases always have a few issues, and we take regressions like this seriously. We’ll figure out what else is broken over the next half day or so, and once fixes for the top few problems are ready, we’ll cut another build.


Major release - no understatement there! Thanks for the fix in advance.

I have the same problem on my Mac mini - no HQplayer sound - looking forward to a quick fix

Experiencing the same issue here. Many thanks for the prompt support with this issue Brian!

A fix for now: try to fill in the actual IP address of your Mac instead of localhost.
This did the trick for me.


What is the estimated timing for build 194+?

I gave it a try, but no luck. Hope it works for some.