Roon 1.3 and HQplayer: No sound after update [Fixed in B194+]

Try assigning a fixed IP for HQP instead of “localhost” - that fixed it for me for now till 194+ is released.

Thanks! That worked. Back in business.

Thank you @SW72 ! This fixed the issue for me.

@Support – very frustrated with this issue & workaround as I change IP’s often (necessitating delete/resetup of HQPlayer in Roon), and use Roon exclusively with HQPlayer. What is the ETA for 194+?

Oh please… The cause has been found and explained, a workaround is in place and a fix has been announced within one day of a major release. Not to mention the edge case of changing IP’s often on a system in use for audio.

If this is a reason to get ‘very frustrated’, I’d guess it’s time for a beverage or two.

1 Like

Just to mention that I had the same problem on audiolinux with roon server. The workaround of the ip a dress instead of localhost works for me as well.

Regardless of your assessment @RBM, which matters to me not at all, I’d love to know ETA to set my expectations properly, @brian .

FWIW, I’d be happy to test upcoming releases for HQPlayer compatibility with Roon on OS X because that’s all I use it (Roon) for, and you don’t have an OS X test setup. I am in the dev field and have a lot of familiarity with software lifecycle. Happy to help.

42 is the answer, and Magritte is fantastic.

I’m having same problem on my iMac. Thought this was some clever way to get us to use Roon’s upsampling. I actually do enjoy the sound quality and like not having to use another app, but still wanted to compare the difference. I also think Roon’s upsampling might be more CPU heavy. It has issues if I do anything other than play Roon. HQ was able to handle websurfing at same time with an occasion hiccup.

I’ll see if the workaround works tonight.

There’s not usually any announcements regarding timing of releases because testing makes such things problematic and creates expectations that may not be met for other reasons.

There are usually a couple of cycles of bug fix releases fairly soon after a major release to pick up nasty pasties that have slipped through the cracks. I would expect to see one or two in the “short term”, but a calendar date doesn’t exist.

That’s not quite true – extensive QA is done on all platforms. As for why this could slip through – Brian’s explanation really says it all. Quickfixes are usually very fast after a major release (first one is out already) - think a day or max a few. Could be hard giving an ETA in such a short timeframe though.

Agreed on Magritte. Keep hearing about 42, but no so sure.

Thanks, that’s very helpful to know Re: Quickfixes, and a fine enough ETA for me.

Don’t forget your towel…

May 25th only.

Hi There,

Count me as one of those with no sound since the 1.3 update. I was going to work with the IT guy at Lampizator tonight, but it’s too late for him to work on it this evening. We’ll try again tomorrow.

I use the LampizatOr DSD Komputer music server with ROON and HQPlayer.



Thanks. Worked for me!

IP Address didn’t work. Couldn’t find HQPlayer. I had globe clicked as well.

Got it to work. Used wrong address. Now to compare sound quality. Going to guess HQ is better at this point.

And just with quick listen HQ wins. Sounds more analog. I think once Roon gets some more filters and options it will close the gap. So if people still want best quality, worth it to still use HQPlayer.

Build 194 is up now. Let us know how it goes, and thanks for your patience!

Dear Brian,

just woke up to to the new build (194) and it works with my MacOS/Roon/HQP setup.

So, I went from (on an emotional scale) wanting to shout at you to being totally impressed how fast you solve issues like this in less than 7 hours (in which I actually slept).

Keep up the good work (and consider a full integration of Jussi’s HQP into Roon)!


Dear Brian

All OK now. Thanks again.


@brian HQPlayer is now working with localhost. Thanks for sliding this into a quick release! If you need help testing HQPlayer on OS X, LMK. Happy to help, as this is all I use Roon for (feeding Tidal to HQP).

Installed build 194 and was immediately able to start Roon/HQPlayer and play music. Thanks for the fast fix!

Awesome support as usual.

Steve Z

I’m on 1.3 build 204, just installed HQP, connected to it in the zones screen, but am not hearing any sound. Is there something special I need to do in HQP preferences to set this up?