Roon 1.4 iOS support very unstable

Hi guys,

Like I said in the 1.4 feedback thread, I think you did a great job with the last Roon update. However, I’m having difficulties getting iOS support stable on my iPad. I was very happy reading it was there and immediately deleted iPeng from my iPad, which I often found to be a bit buggy and not 100% stable. Only to find out, unfortunately, that in my case, Roon itself is much less stable.

I use my iPad 2017 as an endpoint, with my brand new B&W PX headphones (over bluetooth). With iPeng, this worked whereever I was in or around the house. I could leave my iPad in the living room, go upstairs to my study room or even outside to the back of the garden, and it played without any issues. But with Roon, even when I am cooking in the kitchen and have the iPad right in front of me, I get a lot of hickups and errors. When I move 50 centimetres to get some herbs or switch to another app for a recipe, it just skips and eventually stops.

But also without the headphones (and, as such, without bluetooth) I have issues. For instance, when I close my iPad cover, all music playback instantly stops – also no problems with that before when using iPeng.

My favorite use case for iOS support was cooking with headphones. Everybody in the living room and me cooking and enjoying music, disturbing nobody with it. But with Roon 1.4, this use case has become very frustrating: it’s no fun cooking and having the music skip and/or stop every few seconds. Could you please look into this in the new year, after a well-deserved break?

Hi Koen,

Can you describe your network, including all brands/models of routers, switches, boosters etc.

1 Like

Hi Andrew, certainly:

Living Room:
Roon Bridge on Mac mini 2010 Dual Core > iFi nano iUSB3.0 > Chord Mojo > APPJ PA0901A > Klipsch Heresy II (modified filters).

Study Room:
Roon Server on Mac mini 2012 (2.3 GHz i7 QC, 16GB RAM) > Meridian Explorer 2 > APPJ PA0901A > Klipsch RB-15.

Remote & Endpoint:
Roon Remote on iPad 2017 (5th generation) > B&W PX.

Living Room and Study Room (Bridge and Core) are connected via ethernet:
Netgear GS105 5-Port Gigabit Ethernet Switch > AudioQuest Forest CAT700 (5m) with Telegärtner CAT 7 connectors. The Netgear switch is connected to the router/modem from my internet provider.

Thanks for that.

The router/modem supplied by your ISP appears to be the sole WiFi broadcast source. Can you describe it by brand/model ?

How would you describe your WiFi connectivity generally ? How many devices do you have with WiFi connections ? How far away is your router from the areas where you are using your iPad ? How is the signal strength showing in the WiFi indicator at those locations ?

The router/modem is a KPN Experia Box, indeed the only wifi broadcast source in the house.

My wifi inside is generally excellent, downstairs, first floor and attic. Only in the garden it is less strong and stable. The kitchen is roughly six to seven meters from the router/modem. My study room is right above the router/modem, with just a wooden ceiling (old house) in between. No concrete. Wifi indicator shows either full signal or one less.

Please note that in all these locations, Roon worked perfectly on iPad and headphones through iPeng. Only in the lounge set in the garden, behind several obstacles, it was unstable if I moved. Once I sat still, it was stable even there.

Which one of these ?!/devices/all/internet

The v10, Andy!

Thanks Koen, that will help Support get to the bottom of this.

A couple of things to try in the meantime:

Restart your iPad
Renew your IP lease (WiFi Settings in iPad)
Turn off Cellular data on iPad (doesn’t apply to WiFi only models)
Try a different WiFi channel (you can change this in your router)

I think you confirmed in the 1.4 thread that your iPad was running latest iOS ?

My iPad is indeed running the latest iOS. I did steps 1 to 3, don’t know how to do the last one.


I’m reluctant to lead Koen through a channel change unless it is a real prospect of being the problem. My Roon iPad connection is pretty robust. Any thoughts about why his is spluttering, but iPeng was OK ?

You say you did 1 to 3, is your iPad Cellular capable?

Thanks Jeff, and apologies, I misread that part. My iPad is WiFi only.

Guys, I’ve done some more testing and it might be the case that I’ve overlooked something. I found out that when leaving the iPad in the living room (nearer to router/modem), I hardly have any hickups when listening to Roon over my headphones, either in the kitchen, the garden or upstairs.

Now it could very well be that this was also how I mainly tested iPeng, at least in the kitchen and the garden. So it would be unfair to blame Roon for this. Nevertheless, I do recall testing this upstairs with my iPad next to my Mac mini and it worked. Also, the Mac identified the iPad as a zone/endpoint. Now, both with the iPad upstairs and downstairs, my Mac doesn’t see it as a zone.

So there’s definitely still some sensitivity in Roon 1.4 iOS support compared to iPeng, although I think not as big as I initially put it. However, I can’t really test/compare, because Roon 1.4 seems to overrule/bypass iPeng.

If you have apartments nearby then it is possible that the WiFi channel you are using is congested. Most users leave their routers set to the default channel. Changing channels is usually very simple after accessing your router’s user interface.

Accessing the router’s interface is usually done by entering or into a browser address bar and logging in with password “admin”. Your ISP may have supplied different login information.

Once logged in you will find options to change your 2.4 GHz channel (the Experia 10 manual may help). Try a number of different channels and see if that makes a difference.

The Experia 10 has dual band WiFi meaning you could also try shifting your iPad to the 5 GHz band and seeing if that helps. The 5 GHz carries more data but can have a shorter range. The default SSID and WPA2 key are usually printed on a label under the router. Also check your ISP materials for any changed default. It’s always a good idea to change your WPA2 key to avoid strangers leaching off your WiFi. Don’t use an easy phrase here, generate a big random string and keep written and computer records of your new key in various locations.

Lastly, if changing channels or bands doesn’t improve things you might consider a WiFi amplifier or mesh. An amplifier just receives and retransmits and you can adapt any old router lying around to do this (Google or the router manual usually has instructions).

There are also various mesh products that will overlay your usual WiFi network. Roon users, including Danny, have found the Eero mesh to work very well:

@koen ---- To piggy back a bit, on @andybob’s post (:innocent:). I am curious, do you make the same observations while playing directly out of the iPad instead of via the bluetooth headphones?


Hi Andy, thanks for this detailed reply. I have to digest this a bit over the next days and see when and how I can try some of it out. Must admit I’m a bit scared, as I basically have everything working now, afraid that when I change settings I will end up being worse off. I will let you know how it works for me, thanks again!

Eric, I’m not completely sure, so I’ll try again tomorrow and will let you know!

its tricky because it might not actually be the wifi that is tweaking out with koen. From what I understand, he is getting the audio stream via Wifi to his iDevice and then out via Bluetooth to the headset. Without the headphones, I did not get a specific feel from his posts, if the dropouts kept happening or the issue was IOS putting the Roon app to sleep. Bluetooth can also be very touchy about interference and movement.

I would suggest, that he test the various locations with only the ipad and its speakers, or plugged in external speakers. If that goes , well, then add the the headphones back in. I tend to shy away from using bluetooth near the kitchen as I’ve had the microwave cause dropouts and playback issues with Bluetooth.

1 Like

That’s correct, Daniel.

Will do so!

Our microwave isn’t in the kitchen, but in the side kitchen extension (if that’s the correct word? :wink:). But again, iPeng had less issues under the same circumstances. However, @RBM suggested that the settings might (partly) explain the difference. Squeeze (and thus iPeng) send FLAC by default, whereas Roon sends decoded PCM, which is better, but also requires at least twice the bandwidth.

There is a setting under squeezebox devices to prefer Roon to send Flac instead of PCM. I wonder if that setting shouldn’t be made available to mobile devices as well.