Roon 1.5 on iPad crashing frequently

@Support, I recently updated Roon to version 1.5 on my iPad. It plays music just fine, but after I tap on the volume button to bring up the DSP and Settings options, tapping on either the DSP or Settings button crashes the program immediately. It does not matter if Roon is playing music or not at the time of the crash; it happens either way.
I tried deleting the Roon app and reinstalling it, but that did not help.

My iPad is an iPad Pro 10.5 model running iOS version 11.3.1.

Because I am unable to access the DSP or settings options, I cannot provide a screenshot of my audio chain. I am running Roon through an Euphony Audio PTS music server, connected to a Singxer SU-1 USB-to-I2S digital output device, which in turn is connected to a Holo Audio Spring Level 3 DAC.

Here are the screen shots I am able to take:

Thanks in advance for your help!

Hello @Marc_Olender,

Thank you for contacting support regarding this issue, I will be more than happy to help you out here. Moving forward, I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. What this action will do is the next time the application is active on your core device a diagnostics report containing a set of your Roon logs will automatically be generated and uploaded directly to our servers.

The only action that I kindly request for you to do is to completely close and restart your iPad Roon App, you can do so by double pressing the home button and “swiping away” the Roon app to stop it from running, visual steps can be found on Apple’s website here and although you will be using your iPad in this case the steps should be the same as the iPhone 8. After you have closed the App, please make sure to start it again so that we can retrieve the logs when the iPad communicates with our servers again.

I will be sure to update this thread once the report has been received so you know we have it and then we can proceed from there with additional troubleshooting steps.


I think I may have discovered the problem. While my iPad version of Roon updated to version 1.5 without a problem, every time (whether manually or automatically) the update attempts to install the updated version on my Euphony Audio PTS music server core (from version 1.4 to 1.5), there’s an error – “There was an error checking for an update.”

I have a similar issue. Mac-Mini 1.4 Build 310 (64bit) error checking for an update

Hello @Marc_Olender,

Just want to check in with you here and let you know we have been reviewing the logs you sent over to us and are trying to identify any issues you could be experiencing with updating your Euphony device. Our Dev team has commented saying that it could have possibly been due to not having enough free space left on the device to perform the build update. Can you please confirm that you have enough free space on the device and if you do, can you try performing the update again and let me know if it’s working?



I contacted the USA head of Euphony Audio about my problems with updating Roon, and here is what he said:

Marc, we also thought the issue might be disk space but that was not the problem. After extensive investigation we discovered a problem with the Roon 1.5 update. We are currently working with Roon to resolve the issue. Both Roon core and client have the same problem. There is also an issue with Roon 1.5 not finding or holding your sound device. This is regardless of being used with Euphony or not. Hopefully Roon will release an update soon to address these issues. The upgrade failure we believe is a timing issue in Euphony from the way the update is applied since several beta tested have upgrade to 1.5 without issue. But there are still some problems within the Roon update that need to be addressed.<<<

So I guess my support issues are being worked on by your company and Euphony Audio. Thanks for responding to my request for help. I will wait to hear back from Euphony Audio before attempting the upgrade again.


I’m not aware of any issues related to updates. On 1.5. Euphony has not contacted us about this yet.

Your crash is occurring because the iPad is running a new version of the code and the Core is running an older version of Roon. If you can’t take the update, we need to understand why. Can you get us logs from the Euphony?