Roon 1.6 DSP Upsampling to DSD

Yes, I lost all that function in this release. Something has changed and it’s not my gear. This is a software issue/change and I’d like to see about getting it back…

I still have all the DSD stuff, too. I think this is really a support issue. Can one of the mods move some of these posts to a support thread? @Geoff_Coupe, maybe?

Thanks Orgel!

1 Like

Ok so I found the issue! I had changed the volume setting from “Fixed” to 'DSP" so that I could adjust it down when using the Oppo as pre amp. It’s now back and working fine. I did not realize that would turn off the DSD up-sampling…learned my one thing for today, so back to listening it is…:grinning:


Hi. I seem to be having a similar problem but am unable. to solve.
I have Oppo 205 with latest firmware. It is connected to my network via ethernet. Roon Core is on my MB Pro i7 connected to network via WiFi. When I select Device Setup I don’t have any option for DSD max sampling rate or up conversion.
Does Oppo need to be connected via USB?

Found this on Roon’s site with reference to Oppo 205:
“¹ Due to technical limitations within these products, the audio interface available to the RAAT firmware is unable to support DSD or multichannel playback. OPPO is investigating a path forward, but as of now, we don’t know if or when these limitations will be bypassed.”

I have connected to Oppo 205 via USB and still no DSD option.

Hello @Sanjay_Verma,

In the “Device Setup” screen for the Oppo UDP-205, ensure that “Exclusive Mode” is enabled and the “DSD Playback Strategy” is set to “DSD over PCM v1.0 (DoP)”.


Update. Problem solved.
I have Mac OS X Mojave (10.14.5) on MBP 15.4 SG/2.6GHZ/16GB/RP560X/512GB
Oppo 205 with latest firmware

Here are the steps needed (Device Setup, command , or go to Roon menu and select preferences)

  1. USB connection to Oppo (doesn’t seem to work with WiFi)
  2. Device Setup: “Exclusive Mode” YES (this is the option not available over Wifi
  3. Volume Control: Device
  4. DSD Strategy: DSD over PCM v1.0 (DoP)

Then go to the Device on the bottom right of the Roon player

  1. Select your Oppo USB connection
  2. Click on the 'speaker icon
  3. Click on DSP
  4. Sample Rate Conversion: Select “Enabled”
  5. Click on Arrowhead to the right

There you go. That should work. If I determine how to make it work over WiFi I will share that also. However, Roon website seems to indicate that OPPO RAAT firmware is not compatible with DSD.

Found a workaround, but this is a 2 computer solution (Roon recommends 2 computers anyway for better sound). When I bought my new MB Pro I7, I (fortunately) didn’t trade in or sell my old one.

Now I just installed Roon Bridge onto the old MB Pro i5, which is connected via USB to the Oppo 205, with nothing else running. It is connected to the network via ethernet. This also allows for the shortest USB cable since the MB Pro i5 is hidden back behind the TV just next to the Oppo 's shelf.

Roon Core / Server functions are on my new newer MB Pro i7.

I can now transmit / play full DSD upsampling over WiFi from the new MP Pro i7

When I select my device it still appears like OPPO with all the DSD upsampling configurations as above.

Hi all,
With Roon version 1.7 I can no longer do DSD upsampling because there is no option in the menu !
I have not changed equipment (DSD512 capable DAC), the ASIO driver is the same. The only changes were the Roon update.
The option for upsampling DSD is not available in the menu with either Fixed Volume or DSD Volume.
In “Device Setup” I don’t have the option “Exclusive Mode”.
I uninstalled and install Roon and nothing. Appreciate help.

rate%20conversion I

Please raise a new request in the support category and fill in the information in the template there.
Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue