Roon 1.7 build 571 - Message appearing about Metadata issue requiring Roon update

Core Machine (Operating system/System info/Roon build number)
MB Pro 15’ 2.8 GHz 4 cores i7 / 16 GB RAM - SSD
Catalina 10.15.5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Time Capsule Wifi network (up to date as well)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
USB3 link to La Rosita Neutron Star DAC

Since the last update of Roon 7.1 - build 571, the dynamic slider bar is flat upon playing.
A red flag appears indicating that Metadata improver is halted and a Roon update is needed.
But I have the latest version. Can you please explain ?

have you tried rebooting everything?
Are you seeing this on the MB or on another device?

I re booted the core to fix this on my QNAP core

Hi I rebooted the MB Pro that is the Roon Core. I rebooted also the iPad used as front end.
Now I see the dynamic display of audio files. But the red metadata warning is still there.

For information, although I think irrelevant to the issue, I use HQplayer.
Thanks anyway, the most annoying thing was the absence of dynamic slider display, and that one came back.
Best regards and good WE

1 Like

Restart Roon server.

What worked for me when having the issue with the last update was to stop Roon delete the Roon cache and restart. If that doesn’t work I would suggest a reinstall as I also did that as a last step and its been fine since.

1 Like

For what it is worth I am getting this error today (started yesterday). As far as I can tell everything is normal and up to date on my end. Nothing has changed.

Just an observation and perhaps opportunity for improvement on Roon’s part: If nothing else this error message is not as helpful as it might be since it seems to imply an update to software is needed when it is not.

I re booted my core on QNAP to lose that one

I have the same problem. I added an album to my library today, and started up the Roon Remote on my Mac to make sure everything was good. I noticed it was saying “Adding Music To Library” like it usually does, but but below that was the “Metadata Improver” message (atttached screen) that said Roon needs a software update. So, I went to the about page, and it reported the Mac Roon Remote needed an update. It successfully downloaded the update, and Roon restarted, but it still has the same problem.

I reboot my Roon core, closed the Roon Remote on my Mac and tried again when everything came back up, but no difference. The Core and Remote say they are running 1.7 (Build 571)

Please help!

Screen Shot 2020-06-21 at 2.15.21 PM|618x500

Well, I managed to solve the problem on my system. The Ubuntu Linux box I run the Roon core on had some networking issues related to DNS I had to resolve

I get the same issue, rebooting resolve it but this definitely not a fix! I got an average 2 times a week. I noticed you need to turn on the network first, e.g. the router fully power up before turning on the Roon server (I’m using ROCK). I usually off my router every night before going to sleep. My understanding the local contents (either NAS or USB HDD) must be ready before Roon server is fully up and running. May be @support can look into it.

Hello @MusicFidelity, is it the metadata improver message you’re getting twice a week?

I had this same problem last week and the solution that worked for me is here:
Ignore the bit about restarting the core, but follow the instructions under ‘clearing the roon cache’.

My issue resolved - I stopped getting this error message after no specific action on my part I can identify. I had tried restarting the roon server and the Mac mini it lives on more than once with no immediate effect. But later on I saw the error message had disappeared and things were hunky dory once more. I wish I knew why but gut instinct tells me it was nothing on my side that caused it or resolved it.

Was there a subtle (or otherwise!) network issue on the Roon side in the past few days?

I think what makes the situation so worrisome for users like me is the error message which suggests an update is needed when that does not appear to be the case, so it would be great if the busy Roon developers could look into this at some point!

Meanwhile at least for me things are ok.

Thanks to Roon for such a great product and to all here for the great community!!

The issue seems to go away when I powered my internet first followed by Roon server then my USB drive for storing my music. If I don’t power my internet I will randomly get this error message.

Hello CrystalGypsy,
I cleaned out the Roon Cache.
The issue disappeared… replaced by many images not appearing.

Worse, now my Qobuz streaming is NOT working anymore. I actually should make it a new thread. Unless this is unrelated ? But outside Roon, I can access Qobuz and stream from it…


I found a solution apparently: de-register Qobuz (backuped first) then reboot then re-register it.
And the pictures are coming back.

At least this demonstrate there are some inconsistencies in the management of the interaction of recent Roon updates and of the cache, plus with the streaming services. So work for Roon staff in any case (and we are still waiting for nice management of playlist, guys!)

Agreed their is an issue with howd the updates are effecting the cache. Sorry my solution gave you more trouble not had that happen to anyone doing this.

Actually no, it seems the reason why the images weren’t updating was that I needed to increase image cache memory.
Now everything works fine… after a bit of going around.
So thanks for drawing attetion on cache, for me and for other Roon users and staff.


… And yet ! Infamous red warning appears again for now reason.
The rest behaves OK, but…
There is a BUG somewhere about library management.