Roon 1.7(build 667) does not start anymore

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

My computer has a WiFi connection to my router Asus AC88U.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Marantz SA-10 USB-DAC connected to my router with Sonore UltraRendu (USB cable), Sonore UltraRendu connected to my router with ethernet cable.
Oppo 205 connected to my router with ethernet cable or
Oppo 205 USB-DAC connected to my router with Sonore UltraRendu (USB cable)

For the use of Marantz SA-10 USB-DAC I have the Marantz XM ASIO device driver v3.0.0
For use of Oppo 205 USB-DAC I have Oppo 205 USB Audio 2.0 DAC driver v3.34.0

Description Of Issue

Roon worked well from march this year until a few days ago. When I start it now I get the celeb quote screen and then the blank loading screen. But I do not get past this screen, even if I wait for nearly 1 hour. I then have to close this screen.
When I look into the log there is a message about the Marantz XM ASIO device driver “DeviceOpenFailed”.
I have tried rebooting and restarting Roon but nothing helps.
When I uninstall the Marantz XM ASIO device driver, reboot and restart Roon, I still not get passed the loading screen. Looking in the log file I see this message coming back:
“restarting connection (Kan geen gegevens lezen uit de transportverbinding: Een blokkeerbewerking is onderbroken door een aanroep naar WSACancelBlockingCall.)”

Maybe this can be solved by re-installing Roon but I think Roon should be able to handle these errors and start up the Marantz audio connection disabled (with proper error message).

Hello @Joop_Seters, have you tried reinstalling Roon? Also, did you get the drivers from the manufacturer’s site? Lastly, I’d recommend using Ethernet for your core as recommended in our networking best practices. I wouldn’t say it’s related to this particular issue, but is a good note to prevent other issues!

Hi, all my drivers are official and from manufactures’s sites. I never had any problem with my wifi on my computer and all other (audio) equipment is connected to my router via ethernet cables. According to the logs Roon has no trouble verifying my userid and updating megadata.
2 days ago in the evening Roon finally started up correctly and I was able to play tracks. The following morning, with nothing changed, Roon didn’t start up again. I will try to re-install Roon, first make some back-up.

Hello @Joop_Seters, please let me know how the reinstall and connection to Ethernet changes things!

Hi, first of all, ethernet or wifi is not the problem or solution. I cannot start the Roon so I’m not able to see anything in my library, Qobuz or Tidal, I’m far from playing anything.
Reinstall did not solve the problem, I tried every possible combination install options, uninstall, booting my pc, restoring from older backup’s or no backup at all and reinstalling RAATServer. Nothing worked.
I can see in the logs that Roon verifies my userid and updates images, Roon and RAATserver are also allowed in my firewall. So I don’t think that is the problem.
I hope you can help me!

Roon screen 2
This is as far as I get when starting or installing Roon.

Are you running both client and server on the same machine? As in running the roon GUI on the same machine as the server?
Can you see roon from your phone as a client?

I would go to the manufacturer site for your graphics card, not windows update, and install the latest drivers. Often when roon fails at the splash screen it is a graphics issue.

I only running it on the same machine. Sometimes I use the phone app after starting on my pc. If I do that now I get the message ‘Waiting for remote Core…’.
I will look at my graphics card, just in case.

I have the latest drivers for my graphics card installed.

Hello @Joop_Seters, could you please use the directions found here and send us over a set of logs using a shared Dropbox link.

Dropbox, Roon logs, RaatServer logs and 2 extra logs with ReadMe file:


Hello @Joop_Seters, and thanks for sending those logs over. I took a look and found:

 11/24 12:13:49 Critical: scx: in OnBeforeEntry: System.InvalidOperationException: Roep de methode Bind aan voordat u deze bewerking uitvoert.
   bij System.Net.Sockets.Socket.BeginReceiveFrom(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags, EndPoint& remoteEP, AsyncCallback callback, Object state)
   bij Sooloos.Audio.UPnP.DeviceTracker._ReceiveMulticast(Socket s, Byte[] buf)
   bij Sooloos.Audio.UPnP.DeviceTracker.Start()
   bij Sooloos.Broker.Transport.Module.Enable()
   bij Sooloos.Concurrency.EventHandlers.Dispatch(List`1 evs)
   bij Sooloos.Concurrency.SharedState`1.FlushEvents()
   bij Sooloos.Broker.State.<>c.<_InitTransportThreadSync>b__149_0()
   bij Sooloos.SynchronizationContextThread.OnBeforeEntry()

And based on that I’d recommend you run Intel’s driver tool to check for issues with your driver installation. Please let me know when you’ve done this and if you’re able to open Roon after. Thanks!

Done. Only Intel Rapid Storage was updated. Intel software and drivers are up to date now.

Problem is not solved. And critical message is also still there:

Window 10 just came with their newest updates and it seems to have solved my problem. Coming days I will try to restore Roon and all audio zones to the old situation before these problems occured. I think the previous Windows update may have caused the problem or may have been part of it. It crossed my mind before but at that time I could not undo that update anymore.
I will come back on this in a few days.
This is my current Wondows 10 version:
Schermafbeelding 2020-11-28 135145

Now you see it, now you don’t.
It worked, Roon started and I could play music for a while. But then I restored to the latest backup before this all started and I re-installed USB audio drivers for my Oppo 205 and Marantz SA-10. After rebooting I got the same problem again: Roon does not start.
Tomorrow I wil try to restore windows to a previous state and update from there again.
This sucks!!!

Hello @Joop_Seters, my apologies for the continued frustration here. Did the restore help? Also, I’d like to collect another set of diagnostics for our QA team. Could you please try to open Roon one more time and reply here with a timestamp when you do? Thanks!

Hi, Nuwriy
Well, I’m playing music again with Roon for the last 2 days. I will explain in detail the steps I made to first get it not working, and later to get it working again.
But it’s not yet the way it was before and I still cross my fingers every morning when I start up Roon.
I’ll write these details tomorrow, it’s late over here. From there we can discuss on how to go further.

Uninstall Oppo205 and Marantz SA10 USB audio drivers and uninstall Roon and install Roon, going back to previous backup’s did not solve my problem.
Last week I installed the latest Windows 10 update 20H2 build 19042.630. After that Roon worked again
I restored to a previous Roon backup: Roon worked
Then I installed USB drivers for Oppo205 and Marantz SA10: Roon did not work (same problem as before)

Next I uninstalled the USB drivers and uninstalled Roon
I went back to the previous Windows 10 version 1909 build 18363.1198
I again installed the latest Windows 10 update 20H2 build 19042.630.
I installed Roon again and restored a previous backup.
Roon worked again.

After 3 days playing music it seems stable. I have reinstalled the Oppo205 driver with no problems

Somehow the windows 10 update cleaned some settings somewhere. I cannot explain why the Marantz SA10 USB audio driver prevents Roon from not working, even when it is not used.

1 Like

This morning I started Roon without fingers crossed: it didn’t start again, same issue as before
Itried the following to solve it:

  1. uninstall Oppo 205 USB driver
  2. restart pc
    Roon did not work
  3. Uninstall Roon
  4. restart pc
  5. install Roon with restore backup 28-11
    Roon did not work
  6. uninstall Roon
  7. restart pc
  8. Restore previous windows 10 version 1909 18363.1198
  9. restart pc
  10. install latest windows 10 version 20H2 19042.630
  11. restart pc
  12. install .NET Frame work 3.5 and 4.8 (windos update)
  13. install Roon with restore backup 28-11
    Roon did not work
  14. uninstall Roon
  15. restart pc
  16. Restore previous windows 10 version 1909 18363.1198
  17. restart pc
  18. install latest windows 10 version 20H2 19042.630
  19. restart pc
  20. install Roon without restore to a backup
    Roon did not work
  21. uninstall Roon
  22. restart pc
  23. install Roon with restore backup 30-11
    Roon did not work

In the Roon logs I can see the critical messages such as: