Roon 1.7 does not update library automatically

This was first time happening with build 500. 505 did not fixed it.
Roon rock and usb 3 hard disk connected directly to it. I have to
restart Roon to get new albums appear.

Hi @Pertti_Saari,

Starting out, can you share a screenshot of Settings > Storage?

What kind of NUC are you using for ROCK? What are the models of the USB drives in use? Is this happening for all USB drives?


with 6TB Sata drive, USB3 <=> NUC.

That combo has been working well before 1,7. I have not tried with another
external drive

@Pertti_Saari Try disabling your Music Folder and then re-enabling it. This has worked for me with past versions of Roon running on various servers. No idea what the actual cause is though

Hi @Pertti_Saari,

Any change if you disable and re-enable the folder as mentioned above?

Tried it but no help.

Hi @Pertti_Saari,

Roon’s ability to automatically update your library when you add content to the storage location depends on the media location correctly reporting when changes are made to Roon. Often times in situations like this the problem stems from the storage location not properly reporting this.

Do you have another USB drive, even a small thumb drive, that you could temporarily connect to Roon? When you add media to this drive does it update correctly?

Nothing has changed in my setup except Roon version. This has always been working and this behaviour started after 1.7 upgrade. I have 117204 tracks in my library now.

Hi @Pertti_Saari,

I wanted to check in and see if you’ve had the chance to give this test a go:

It’s started to work again. Don’t ask me why :).

1 Like

Hi @Pertti_Saari,

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

Hi - My library has stopped updating automatically - I’m having to force rescan in order for Roon to see the newly ripped albums. Core is running on Sonictransporter i5 CDR.

Any tips would be much appreciated!

Start a new support thread and enter your details in the form it shows you.

I had this issue on an Ubuntu Roon core server. What I did is to increase max open files and inotify watchers and reboot:

vim /etc/sysctl.conf
fs.file-max = 200000

If you are scared of the high numbers start with a lower one.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.