Roon 1.8 Bricked my iPhone X

Core Machine (Operating system/System info/Roon build number)

NUCi7 running ROCK 1.8

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC is connected to Google WiFi base station via Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iPhone X

Description Of Issue

I went to sleep with Roon1.8 playing on my iPhoneX and woke to to find it locked on the Roon screen with no ability to close the app, open other apps or turn off/reboot the phone. I will have to wait until my phone battery runs out and powers off before I can use it. This is a huge issue because I need my phone 24/7 for business and Roon has bricked it. Please fix this; otherwise I will not be able to use your otherwise great product.

Is there not some reboot sequence by pressing and holding 2 buttons?

EDIT:

.sjb

5 Likes

Good call. When you have any computer based product, especially Apple, the first thing you learn is that when/if it locks up, there is a two button sequence to reboot and clear the device. I have had Macs, iPads, iPhones…iPods…that would freeze. A simple forced restart and all is well. Hope that is true for the OP.

There is but it doesn’t work

've been an iPhone user since the first phone and I’m well aware of the restart sequence. However, it doesn’t work in this case.

Wow, lot of condescending users here. Of course I tried the reboot sequence and stated that in my original post.

I thought the replies were designed to be helpful and empathetic. I saw others offering that as a suggestion. In either case, I hope that you find the solution.

1 Like

Sorry if I misinterpreted your response but I did state that I could not reboot in the post

Sorry for the trouble here, @Robert_Brown1!

We haven’t seen any other reports of Roon causing this type of issue, and it’s definitely not common for an app to be able to cause this type of behavior. We’re definitely happy to investigate further, but first I think you should try a recovery to get your device back up and running. Please see instructions for this below:

  1. Connect your device to a computer. On a Mac with macOS Catalina 10.15, open Finder. On a Mac with macOS Mojave 10.14 or earlier, or on a PC, open iTunes.
  2. Locate your device on your computer.
  3. While your device is connected, follow these steps:
    • Models that don’t have a Home button: Press and quickly release the Volume Up button. Press and quickly release the Volume Down button. Press and hold the Top button until your device begins to restart. Continue holding the Top button until your device goes into recovery mode.
  4. When you get the option to restore or update, choose Update. Your computer will try to reinstall iOS or iPadOS without erasing your data.

This comes from Apple’s website.

1 Like

Thanks. The phone’s battery died and after I charged it and rebooted everything was fine. I have not tried the Roon app yet though but will report back if I continue to have the issue.

1 Like

Hi @Robert_Brown1

Have things worked okay since your last update?

Can report that Roon is now stable after allowing the battery to drain and rebooting. I also installed the latest update and with the exception of the occasional failure of Roon to recognize the phone, everything is working well.