Roon 1.8 (Build 1105) not working on Nucleus, can I get previous installation file?

Roon Core Machine

Neucleus Rev B

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

After updating the new(Build 1105) software, I can’t access all music files in my Nucleus Internal Storage. And Roon APP is always reading but can’t show any music. Can I have the previous version file to install in my PC and Nucleus? Thanks

Just a fellow user here, and a non-nucleus one at that, but allow me to ask, if you’ve installed 1105 on your remotes as well?

Hi @Mark_Li,

Are you able to connect to the Nucleus?

If so can you goto the Web Administration Interface and post a screenshot here of what it displays.

PS It’s always worth a reboot, as a troubleshooting step … have you tried that?

Hey @Mark_Li,

Ben here with the support team, I wanted to check in on this thread to see if you were able to get your library storage squared away?

Both @Carl and @Marin_Weigel are steering you in the right direction for next steps. I’ll be monitoring this thread for your reply :+1:

1 Like

Hi @benjamin,

Thanks for @Carl and @Marin_Weigel’s help. Please see my reply below

  1. I can connect to my Nucleus.
  2. I reboot many times and reinstall Nucleus and Roon app on my Windows.
  3. I only install Roon on my PC and Nucleus when the system ask me to update. It works good before installation.
  4. Web Administration and Windows Roon screenshots are attached.

Now I still can’t access my music and find any audio devices in Roon. And it shows TIDAL login failed after I input correct ID and password.

Please let me know what can I do next. Thanks!

Mark



Did you also try rebooting your router and any other network equipment?
If not try then it’s worth a go as typically this Tidal error is related to network connectivity.

Also worth trying:

  • Remove the Tidal account from Roon
  • Reboot the Nucleus
  • Create the Tidal account in Roon again

If neither of those work, then I think it’s time for Roon to take a look at your log files.


For the music files on the internal SSD, I’m assuming your Nucleus was fitted with a second SSD.
Let’s check if Roon is pointing to it, if you go to Settings → Storage it should be listed a a watch folder.

Can you post a screenshot of this page, a that will also help Roon’s support team.

@Carl,

Thanks for your reply. I tried all procedures you mentioned but still can’t solve my problem. The TIDAL original app runs well on my windows.

I did use a second SSD in my Nucleus. The screenshot is attached. Is there any procedure I can go back to Roon 1.8 (Build 1021) which works good?

Thanks,

Mark

Thanks for that, it looks ok to me. I’m sure you have done this already, but as a test are you able to see your music files on that internal SSD via the network share? Just wondering if the disk and it’s content are ok.

Roon do not support reverting to an earlier version, but I doubt that’s the issue here there are hundreds of people using B1107.

More likely either a problem with the Roon Database and/or a hardware issue.

You could try restoring a recent DB backup, however, before doing so make a new backup of the DB so you know you can restore back to this state if needed.

After that, I’m unfortunately out of ideas and we are back to having Roon’s @support look at this for you.

Hi Carl,

Thanks for the prompt reply. I can see all my music files in \nucleus\Data\Storage\InternalStorage\Roon Imports.

Unfortunately, I don’t have a DB backup. I started using Nucleus a week ago. I think the problem may not only on DB. I can’t access my music folder on my PC in Roon app and can’t use any speaker of my PC. Hope @benjamin can help on this asap. Thanks!

What is curious about your Settings > Storage screenshot is that there is only the message “Watching for new files in real time”. There should be a count of the total number of files that the Core has imported as well.

Can you click on the “3 dots” menu and force a rescan? Any difference?

I did rescan it earlier but the situation is still the same.

However, I just reset Database & Settings and all the problems solved. But all data needs to rebuild. Really appreciate the help from @Carl, @Marin_Weigel, @Geoff_Coupe and @benjamin.

Thank you guys!

Mark

@Mark_Li, I am curious about your situation.

It looks like your Roon library was messed up. Do you take Settings==>Backups? If you do, and assuming you were on a recent Build when the Backup was taken, didn’t you get a message complaining about a corrupted library?

If you take Backups and you didn’t get a library corrupted message then the Backup logic still has problems.

Hi @xxx,

I already asked about backups, it’s a new system (just a week old) and non had been taken.

Totally agree they are important of course.

My concern here is what happened to corrupt the DB, a one off (it happens) or a more systematic issue? Only time will tell … and we’re back to how important it is to make regular backups.

1 Like

That’s really good news @Mark_Li.

Once you have the system setup and files imported … as @xxx and I have just been discussing… please make sure you take regular backups.

I have scheduled backups setup in Roon, and they take care of themselves once configured.

Check this out for more information…

Thank you @Carl. I already schedule regular backup. Hope this won’t happen on next firmware update.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.