Roon 1.8 (build 778) Feedback

Maybe a setting I haven’t found, but “shuffle play “ still limited to 5000 tracks. Yes I have rebooted my system. Please fix this. All else looks great so far. Keep up the good work.

3 posts were merged into an existing topic: Display issues on 1.8 B778


  • Scroll position doesn’t persist between pages

This bug definitely was fixed for Albums section, but still exists in the Recent activity section.

And still no track numbers in the playlists! But why?! Is it so difficult or are they bothering someone so much? Why can I select Dynamic range or Plays and Last played, but cannot select such a simple option as displaying track numbers? This is just ridiculous.

You are right. It doesnt work on my Win 10 PC neither.
It is simply not repaired yet.


A post was split to a new topic: Issues on several songs that were playing normally before

I love the update, especially how the Roon team upgraded the Focus possibilities with and/or options. Thanks! I can now e.g. focus in My Tracks on music that has both a “Dancing” and “Uptempo” personal tag but are not in the “Jazz” genre. The possibilities are limitless. Hallelujah!


Build 778 release notes says that it was fixed:

  • Fixed missing albums on Discography tab in certain cases

But I’m still experiencing this issue. In some cases Discography doesn’t show local albums. Support topic is here.

1 Like

Release notes btw:

Still no app in Google store in UK.

The issue was that Shuffle only selected from the first 5k tracks of the active sort.

Since build 763, shuffle has returned a random selection of 5k tracks across the whole of a user’s library.

1 Like

so far, so good

except blinding “white screen” from iPad/Phone wake up


I know that, but that is not the way shuffle should work. Shuffle all is shuffle all and you don’t need to have a queue of songs listed, only the next. This is how it was in 1.7 and this is the way I hope it will be in the future.


Is the android update required?

Yes! My Bookmarks (of which some of them hold several hundred Albums) work again in this update! Thanks Roon team :smiley:

My only remaining issue now is that the filter takes up almost 80% of the screen, perhaps we can get a more elegant way of showing the tags? As displayed in this screenshot, I have room left for 2 rows of albums.


Hi all,

After the update, if I add an album that is not identified, the discography overview on the artist is blank.


If I now click on the artist name from the album view and enter the artist discography, it is blank:

I have tried editing the album to make sure Primary Artist is correct on both album and track level, but no effect.

Anyone else experiencing this?

EDIT: It is not only for unidentified albums. I now see the same on several of my artists…
It seems to be affecting all artists that are created, either manually (created in cases where the album originally was connected to the wrong artist) or automatically (by adding an unidentified album).

This is a critical error for me, as many of my artists are affected like this.

EDIT2: I have created a support post on this now: Discograpy empty for several artists after 788 update


If you haven’t already, you should post a new Support topic.

I’m not aware of this being reported or Roon promising a fix back to the previous behaviour.

I also prefer that shuffle would behave the same way as in 1.7, though I’m not sure it makes a difference if the first 5000 tracks are randomly selected upon pressing shuffle or whether each track is selected randomly track by track during the actual playback.
Maybe randomly pre-selecting 5000 tracks is better for overall performance?

1 Like

New build seems great but I don’t understand why the number of tracks in tracks view has not been restored. This is an issue since 1.8.
You can’t see how many tracks are in the list when in “tracks” view, and when focus filters are applied you don’t have an indication of how many tracks out of the total are now filtered.
It works fine for album, artists and composers.

I think it’s worth fixing.


Yes, I just noticed this too. I was already trying to figure out if this was just a temporary glitch (page loading slowly or something like that), but it looks like it’s indeed a bug.