Roon 1.8 (Build 846) not working on sonictransport i9 [Solved - Update Roon through]

Not able to access roon core right after upgrade.
According to MySonicorbiter roon core seems fine.

But roon app on my iPad doesn’t recognize.
Same as my iPhone and MacBookpro.

I have restarted my system I9, router but nothing change.
Any advance or solution?

Are you using a VPN on any of your devices? I only see that message when I use a VPN on my client devices – especially after restarting the service. Disabling it briefly then brings it right back. I can then re-enable the VPN and continue as normal.

Sorry I am not able to be more helpful.

Hi. I never use VPN.
Thank you for your help.

Are you on sonicorbiter 2.8? Have you tried to manually trigger an update from Apps > Software Manager?

Yes. I did.
I have tried to update it again manually. But still the same.

I tried to update again and it works!
Thank you very much !

It is amazing how disappointing it is when you lose your music – glad it was resolved! Enjoy!

It really was.
Thank you again. You are my lifesaver ^^


Same issue for me. Solution doesn’t work though. I’m on 2.8 for sonicorbiter and “Version 1.8 (build 846) stable” for Roon server on the i9.

Any thoughts @support ?

You need to upgrade it manually even you are already version 2.8. Please try.

1 Like

Ah ok yep so keep clicking though on the Roon icon in the software updater area.

And then force the install.

Thanks @KENKEN !

1 Like

I have the same issue with my Sonic Transporter i9. I had Andrew Gillis log in to my computer and somehow he got the new software to work. Had to uninstall and reinstall a few times from the software updater page. Wish I knew what the issue was? But it took around 2 plus hours to re-install and then restore from a backup. I seriously hope any future updates won’t involve this extra work. It seems it’s happened to a few of us ST users. I hope maybe someone at Small Green Computer or Roon Labs can test to see why it didn’t update flawlessly? I know there where certain things like libicu (sp?) and things necessary for all of this to work. Once we got it installed, it runs stable.
I’m thankful for everyone’s help though. Just want to keep @agillis and @support in the loop as multiple folks have had issues with this new update.

Hi All,

Thanks for the reports here and for the clear update steps with screenshots! Thanks for bringing this to our attention, it will surely be helpful to any other users facing similar behavior!

You don’t need to reinstall Roon. All you need to do is press the update button → manage → apps → software manager → update


Finally after trying everything multiple times, finally, it worked per Andrew Gillis’ method just above. For some of us less adept at computerese, to have what “press the update button” means and where to find it is most helpful. I was so fearful of unhinging things even more, the quite explicit instructions of going from sonicorbiter to manage to apps to software manager to update was what did it. So happy to have music back and better than ever!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.