Roon 1.8 (Build 933) Feedback

I get an error on Roon ROCK when trying to update.

First try was an epic FAIL: slow, constant “adding music to library”, loss of connection with various remotes (laptop, Fire tablets, iPads, iPhone). Absolutely terrible.

Rebooting and will update in a few minutes.

After rebooting my Roon Core (just the Roon software, not the entire computer and operating system) things appear to be back to normal. My Roon Core runs on a Window 10 computer and most times a reboot of Roon straightens things out.

Is this with local or streamed content? I just tried both and I also “clicked ahead” on the same song and didn’t have any issues.

Perhaps I was too quick with my statement. I restarted my Nucleus and now it’s fine (with Qobuz). If I was wrong, sorry.
I will test tomorrow with different sources (local and streamed).

2 Likes

Installed easy on my QNAP TS-364. Works.

But it does not help to fix the “Music files not found” Problem which is here since i started to use roon on this new NAS instead on a NUC with the Music-Files on the NAS only. I can play Radio and Stream Music from Tidal. CPU load is load and it works fine. But i like to listen to my music files.

1 Like

I am very happy with build 933. Not only does it seem to have resolved a very annoying bug (Loading artist screens crashes Roon remote client), but it loads album, artist and discography screens faster than ever before.

If replacing legacy code is what it takes to make Roon a much more stable and responsive system, by all means continue doing this, instead of adding new features.

3 Likes

Did the update right before exercising and half of my exercise playlist was unavailable. Later discovered that the update logged me out of Qobuz. Bit of a nuisance that!

1 Like

Yes very sad to see still no fix or even progress on QNAP - Not Showing Local Folders Anymore [See Staff Post - Guest Access Temporarily Resolves - Ongoing Investigation]

After thoroughly listening to a couple of albums, both local and streamed, I feel now enabled to confidently speak about the most important topic in all the new build feedback threads—namely, sound quality.

Well then, I feel very certain that the sound quality of Build 933 is at least as good as that of the previous build. Maybe better, and maybe not. There you have it.

10 Likes

Not sure if this is the right place to say it, but I think the recent transition to more frequent updates vs. the less frequent “Big Bang” sort of approach is a good thing. Delivering continuous value in a more agile manner seems like the mark of a maturing product. As a lifer and nucleus plus owner I really appreciate this evolution.

Thanks.

16 Likes

Can’t connect to any of my remotes. Pretty much bricked the nucleus for all practical purposes.

Everything works. No issues so far (MacBook M1, Android phone as remote).

No complaints

1 Like

That’s exactly, what’s happening with my Android 11 OnePlus Nord!

No issues with update, apart from the fact that it seem resource intensive. RAM utilisation has never been this high, more than 58%, the day after update. I restarted the server and it did not make a difference.

1 Like

No issues.

Database updates can take a long time to perform dependant on size of library. How long did you leave it running. It’s not wise to do anything at all in this state as it will trash it if you power it off.

I am a newbie to Roon (currently in my trial period) and the is my first update. I have my core installed on a Mac Studio Max and just want to report that Roon crashed twice when restarting. The third time it opened fine and updated the database.

First time I had an issue after a Roon update since I’m subscribed as a lifetimer (26 July 2017).
Message: “something wrong with your library”.
Restored the latest back-up and everything is fine now.
I do daily back-ups to Dropbox and keep the last 99 versions.

It crashed. I did not stop anything.

DB Restore failed at 58%. Then the ST crashed.”

Pretty sure Linn needs to fix how the streamer talks to Roon. Not the other way around.

If roon was the issue , other streamers from Cambridge or bluesound would have problems too