Roon 1.8 cannot ‘see’ Ropieee hosted RoonBridge - But works fine with DietPI Allo

OS Name Microsoft Windows 10 Pro
Version 10.0.19042 Build 19042
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name CBALIEN
System Manufacturer Alienware
System Model Alienware Aurora R11
System Type x64-based PC
System SKU 09A3
Processor Intel® Core™ i9-10900 CPU @ 2.80GHz, 2808 Mhz, 10 Core(s), 20 Logical Processor(s)
BIOS Version/Date Alienware 1.0.1, 6/12/2020

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

** Update: I switched over to DietPi allo and things are working fine with Roon 1.8. So at this point I would say that the issue is with Ropiee 1.8 running RoonBridge 1.7.

Ropieee 1.7/1.8

After forced update to 1.8 and now Roon does not recoginize/find/see my Ropieee bridge. I updated the Ropieee to 1.8 and still Roon cannot find the device. My network is super solid and I had been using Roon 1.7 with zero issue. Now I have a pretty much useless system. I have wasted hours trying to figure out what went wrong. I wish I had checked the boards before and would have seen that Roon 1.8 is a bad release.

Here is the RoonBridge_log.txt from the pi running Ropiee 1.8:

02/13 10:17:19 Info: Starting RoonBridge v1.7 (build 571) stable on linuxarmv7hf
02/13 10:17:19 Trace: [rnet/RnetJsonServer] Listening on port 46339
02/13 10:17:19 Trace: [roonbridgehelperserver] SOOD announce
02/13 10:17:20 Trace: [rnet/RnetJsonServer] [client 192.168.254.35:53144] GOT {“request”:“updates_
subscribe”}
02/13 10:17:20 Trace: [rnet/RnetJsonServer] [client 192.168.254.35:53144] SENT NONFINAL {“status”:
“Success”,“updates”:{“is_supported”:true,“status”:“UpToDate”,“progress”:null,“current_version”:{“m
achine_value”:100700571,“branch”:“stable”,“display_value”:“1.7 (build 571) stable”},“available_ver
sion”:null,“update_mode”:“AutoCompatible”}}
02/13 10:17:32 Trace: Successful POST response from https://push.roonlabs.com/push/1/connect
02/13 10:17:32 Trace: [push] connecting to 35.196.8.166:9200
02/13 10:17:49 Trace: [appupdater] initial check for updates
02/13 10:17:49 Trace: [rnet/RnetJsonServer] [client 192.168.254.35:53144] SENT NONFINAL {“status”:
“Changed”,“updates”:{“is_supported”:true,“status”:“Checking”,“progress”:null,“current_version”:{“m
achine_value”:100700571,“branch”:“stable”,“display_value”:“1.7 (build 571) stable”},“available_ver
sion”:null,“update_mode”:“AutoCompatible”}}
02/13 10:17:49 Debug: [base/updater] Checking for updates: https://updates.roonlabs.com/update/?v=
2&serial=4C40C9FD-5486-4116-AEDA-AB1618E2BB7B&userid=&platform=linuxarmv7hf&product=RoonBridge&bra
nding=&curbranch=stable&version=100700571&branch=stable
02/13 10:17:49 Debug: [appupdater] Update not needed
02/13 10:17:49 Trace: [rnet/RnetJsonServer] [client 192.168.254.35:53144] SENT NONFINAL {“status”:
“Changed”,“updates”:{“is_supported”:true,“status”:“UpToDate”,“progress”:null,“current_version”:{“m
achine_value”:100700571,“branch”:“stable”,“display_value”:“1.7 (build 571) stable”},“available_ver
sion”:null,“update_mode”:“AutoCompatible”}}
~

Per the italicized log lines it looks like my roon core pinging the pi.

Network sniff shows my roon core host connecting to the ropiee:
roon core host ip is 192…35 and ropiee ip is 192…30

I have a wireshark capture file of roon core → ropiee if you want it.

The ropieee bridge shows up here:

But not here:

So what’s the plan? Can we rollback to 1.7?
/nothappy

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

TEXT GOES HERE

Description Of Issue

TEXT GOES HERE

Same issue here

I run 1.8 and Ropieee without any problem. Have you tried to disable Ropieee extension in Roon and then activate it again?

bump.

@ Fredrik_Andersson I dont’t know what you mean by disable/enable ropieee extension. The Extensions tab under Settings shows no extensions?

A 3 day weekend without running my main system sucks…

Spent another hour and setup a Pi4 with DietPi allo and have my main system up and running again.

I had the same issue. It took me hours. They’re still working on why my database and settings won’t load, but I did get Ropieee set back up in the interim since it’s my primary music source.

My specific fix required 4 steps, none of which should have been required with a good update, IMO. However, since I had to start again from scratch, YMMV.

  1. Had to re-enable the Spockfish Extension under Settings / Extensions in Roon.
  2. For some reason Ropieee switched to AirPlay vs. USB out. I had to switch that back.
  3. I had to go back into Ropieee and match the Roon Control Zone to the Zone name in Roon.
  4. Forced Ropieee to Restart Roon Remote Extension

Hope it works for you.

If it dont show any extensions then I suggest that you try what @Patrick_Anderson wrote.

As my Ropieee systems works I have not done anything like this right now but I would start with Ropieee it self to see that alla settings are ok in there, control zone and zone name, restart Roon extension and see if thet will bring back the Ropieee extension in Roon under extension tab.

I just use the Pi3 with Ropieee for the screen and remote controll not my main audio output.

Had the same issue. I initially thought it was RopieeeXL, then the same thing happened when I switched OS on my Allo USBridge Signature to MoOde and DietPi (haven’t tried VitOS yet as it is for Pi4 and Allo USBridge runs on Pi3). However, each time I was able to make it work again by rebooting Roon core on my Synology DS1019+. I now think it is the Roon 1.8 causing the problem.

1 Like

Same here, rebooting Roon Core worked, I hope they fix it soon.

Hi All,

Thanks for the feedback here, we are looking into this.

Hello,

For those impacted by this issue, can you please confirm if there’s been a change in behavior since we shipped our latest RoonBridge release? Thanks!