Roon 1.8 does not see local folders on Linux ZFS drive [Resolved]

That makes this extra odd as it would mean Roon is completely broken on Linux, which doesn’t seem to be the case as there would be a lot more error reports/complaints if it were.

I really wish someone in the Roon team would come here and acknowledge this issue and give us some kind of roadmap/ETA for the fix.

Absolutely, this lack of response just sucks. With no way to downgrade, I’m effectively sitting on thousands of dollars worth of bricks scattered through my house. I mean, I guess I can use TIDAL and Qobuz, but I’d prefer to play from my local library and have my playlists actually work.

They collected log files and changed the thread title (added [Team investigating]).

It’s not much but I consider this feedback although a rough timeline or status update would be nice.

Although this is a nasty regression coming from a corner case of Linux file system setups, let’s give the Roon team some room to fix this.

I’ve no problems with giving them room to fix it, but this should have never showed up in a major release. ZFS root on Linux has had major pushes into the consumer base over the past few years, especially so with the Ubuntu releases. I’m not directly blaming the developers because bugs do happen, but I do have problems with the poor QA that leads to a showstopper bug like this showing up in a release.

I’d call it a one off, but the vast majority of the major bugs that came with 1.8 could have been easily caught with proper testing. If you’re going to support a platform, you absolutely need to be doing the basic tests with every major distribution and probable configuration. It takes time and effort, but it reduces the lost of revenue from cancelled subscriptions.

Instead they have a portion of their paying user base stuck without the software/service for which they’ve payed, and for an extended period of time. If this were a free software/service, I’d rage a bit then shrug. But this is not an overly cheap piece of software to run, especially so for those of us who put out the chunk of change for the lifetime.

But yes, there is not much we can do other thank sit back and wait.

p.s. I come from industries where five nines uptime is the way of life, so my rage gronks are related to personal and business ideals.

Any progress on this issue Room team?

I have been out of music for a week and no feedback has been shared on the progress or plan for resolution.

Why not just reuse the 1.7 code for this part of the app?

I’m having the same issue! Using NixOS with ZFS as my host (and since NixOS’s philisophy is unsupported as per Latest Roon Server is not available for download on NixOS - #12 by Bernardo_Meurer_Cost - I run it in a ubuntu docker image)

Looking forward to a resolution to this, since I can’t really use 1.8 until it can load my music :laughing:

Nice to see someone else loves music and NixOS @Bernardo_Meurer_Cost

1 Like

Still not a word on this show stopper issue?

Pretty incredible…

Yeah, it’s been a week now that my system does not work.

@noris are there any news here?

Hello All,

I discussed this issue with QA today and the investigation is still in progress, I don’t have any specific updates I can share at this time but thank you in advance for your patience while we look into this issue further.

2 Likes

Thanks.

Could you please inform where they stand?

  • has the issue been reproduced?
  • is the root cause understood?
  • has a resolution approach been identified?

Thank you.

1 Like

After some investigation today I can confirm that Roon core doesn’t respect PATH and instead hard-codes /bin/mount.cifs and /sbin/mount.cifs as well as /bin/umount and /sbin/umount.

This is disappointing.

@noris I see the status here was updated for “Ticket In” - What does that mean for Roon development?

Does it mean:

  1. The issue is now acknowledged by the team, that’s it.
  2. The issue is scheduled to be solved before the next release.
  3. The issue will be solved eventually, no guarantees.
  4. Something else?

Hello All,

I wanted to touch base with some good news, which is that our QA team has been able to reproduce this behavior in the QA lab and we’ve opened up a bug report with our developers.

As per policy, we can’t specify an exact timeline of when this bug will be resolved, but getting the issue reproduced in-house is the critical first step towards resolving an issue.

We are actively working on this issue and we will keep this thread up to date as we have more information to share. Thanks again for the reports and for your patience here!

4 Likes

Thanks for the update

Since this is a regression from 1.7 a comparison of the source code handling the linux file access may help

Cheers,
Bernard

Is there any chance we can have even a rough idea of when a fix will be out?

It’s been two weeks now since I’ve been able to listen to music :confused:

Well, 1.8 Build 763 doesn’t appear to fix the ZFS root problem.

Any status on when it is going to be fixed? We’re 2 weeks and two patches in, and still unable to access local files. Pretty unacceptable.

It looks like the good people of Roon may not fully understand the reason of their success.

To me, far beyond great UI, amazing metadata handling, good sound… there was stability and quality. And this bug, although it probably only affects a small part of users, reveals worrying issues in terms of platform policy, QA coverage, customer support communication and above all speed of reaction.

This defect impacts the most basic function of the software, the only one that truly matters, the ability to play music. In the online world it’s called an outage. Most companies publish on their websites a public hourly status update. It should be P00 and the CEO should get a report about progress twice a day.

I wonder how many of us are life long owners vs monthly subscribers btw? I am a life long owner.

1 Like

Lifetime here as well. Otherwise I’d have already cancelled my subscription and migrated to something that works reliably.

I can confirm the latest update also does not solve this issue for me.

Bingo. In the fintech or service provider worlds that I do systems engineering in, we’d be all hands on deck if we had a showstopper this big. People would be fearing the pink slip and the company would be fearing legal repercussions.