Roon 1.8: Incorrect/Missing Album Art and Search Issues

Version 1.8 (build 764) stable

Ever since the latest updates, I’ve been experiencing the following issues:

  • Albums added from Tidal show a generic genre image (Started happening 5-6 days ago)
  • Android and iOS tablets don’t display album art after they are minimised/restored or sometimes not at all.
  • Search often doesn’t work
  • Using the Tidal tab doesn’t work well (the page doesn’t load)

Previously I had no problems and almost never had to reboot, but now I’ve tried restarting and that doesn’t help either.

Hey @Bob_Goad,

Thanks so much for getting in touch about the issues you’ve been running into lately. We’d love to help you enjoy Roon on the 1.8 version just as much as you did on 1.7. Let’s get started.

Could you please try:

  • Logging out of Tidal in Settings → Services
  • Rebooting your Core (this means holding down the power button until the Core is turned off, unplugging for 30 seconds, plugging it back in and turning it on)
  • Logging back into Tidal in Settings → Services

Please, let me know if this helps with the first and last issues you’ve mentioned.

As for your Android and iOS tablets, are they running the latest version of Roon? Have you tried reinstalling the Roon Remote app?

When you say “search often doesn’t work”, could you please be more specific? It would also help us very much if you could please detail your setup:

Details on your Core machine (OS, Hardware specs, Roon build)
Details on your Remote(s) (OS, Hardware specs, Roon build)
Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
Audio devices in use
Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)

Thanks in advance :pray:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.