Roon 1.8 iOS not working with Core 1.8

### Roon Core Machine MacMini i7 running High Sierra 10.13.6

Networking Gear & Setup Details

All Ethernet connected, except the iPhone over ### Connected Audio Devices

Number of Tracks in Library

Description of Issue

See screenshot. Roon 1.8 legacy app on iPhone or iPad does not recognize the Roon CORE 1.8 server

The core will need to be changed to 1.8 legacy as well, you can’t mix and match.
This may help.

And this.

I have the same issue as Freferick. I followed all the instructions in 1.2<->2.0 migration FAQ. Now my core is 1.8, my roon remote on windows PC is 1.8 legacy, and the roon remote refuses to connect to the core. Help @support

Same here. Followed the steps on my Rock. Created the branches folder, downloaded the roon_1-8, renamed it roon, put it in branches, reinstalled system and still ended up with 1105 and not legacy 1126. I have posted twice and still no answer.

1 Like

Ok, partially resolved.
Had to go to downgrade page and install the MacOS all-in-one version
Now MacOS Roon reads version 1.8 (build 1126) production 1x
which matches exactly the iOS legacy app 1.8

Problem is that I have to recreate all settings, music folders and output devices, the iOS app is rebuilding the library, and for now it doesn’t see that the Core is playing something

Shouldn’t restoring a database backup take care of that?

Why is this post showing as the accepted solution to this topic when the poster is clearly having the same problem as me which is not resolved?

1 Like

I have been meticulous about the case and I have tried the process half a dozen times.

  1. I created a folder called branches on my Rock /Data share
  2. I downloaded roon_1-8 which is 12k long.
  3. I copied the file into the branches folder previously created
  4. I renamed the file to roon.
  5. In the interface I selected reinstall.
  6. After a couple of minutes my core was still on build 1105.
    I am left with a 12k roon file in branches.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.