Roon 1.8 is completely broken now

Core Machine (Operating system/System info/Roon build number)
Asus mini PC running Roon Rock
Version 1.0 (build 227) stable
Version 1.8 (build 764) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Xfinity Router everything on Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
RPI4 running RoPieee into Mytek Liberty
Bluesound Node 2i
Google Chromecast

Description Of Issue

Roon is almost completely unusable since version 1.8. I encounter the following issues:

  • Search does not show anything (endless loading)
  • No Album art except sometimes
  • Newly added albums show generic images, not album art
  • Often Tidal recommendations display they are unavailable (restricted)
  • Errors that I need a software update for metadata (restarting the core fixes this for awhile)
  • Bluesound Note popping sound every so often.

Basically the whole point of using Roon is ruined since these last couple of updates. All my tablets Android/iOS/PC display the same problems. I just paid my yearly fee again and I am very ■■■■■■ off that it’s no longer working correctly anymore.

You mention the core version. Are the remotes on 764 as well?

Yes, sorry… All the remotes and PC are updated to the latest version.

Rebooting everything in my house seems to have worked for the time being. I haven’t checked the popping noise in the bluesound though.

1 Like

I just noticed it lately… but I do see there are a few people that have mentioned it. Thanks for the help!

1 Like

Doing a factory reset of the bluesound has fixed it for some people.

1 Like

Unplugging and restarting the Bluesound seem to have fixed the issue. Thanks!

1 Like

Time honored IT solution

Turn it off and turn it on again :rofl::rofl::rofl::rofl:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.