Roon 1.8 keeps crashing - please give us a stable version!

Hello beta releasers!
1.8 is definitely a catastrophe, not even a beta version. I payed for a lifetime licence because I had trust in your company and application, not any more. Version 1.7 and before, it was no stability problem for years, just worked perfect for me. With alpha-version 1.8 I have to restart my dedicated Windows 10 PC every day and the only change is 1.8 disaster. Everything worked smooth before that.

Can you solve the problem by going back to working version 1.7 and continue alpha/beta-testing with a special group and not your life time paying customers. Alternatively pay back the life time fee so I can lock for a better solution.
Best Regards,
Software developer for 35 years and hifi-entusiast for 55 years
Lyngdorf, Dali, TIDAL HiFi and more…


Hi @Peter_Olausson,

Whilst there has been problems with 1.8 for the vast majority of users it is quite stable, though it does seem there are still some reports of functionally issues.

I’ve moved your post to the #support section of the Roon, so Roon support team can follow this up for you.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hello again
Sorry but I’m not so interesting to put efforts in “not stable/working software” that I have payed lifetime license for. I think serious software developer should do proper testing in different situations BEFORE delivery. I’m not alone, a lot of users have problems.

Version 1.7 and before worked perfect for me. I have made no changes and with 1.8 RoonServer stops and or hangs the headless PC. It happens ones a day or perhaps more.

I have made a temporary solution in meantime awaiting a stable version. In midnight I stop RoonServer.exe and start it again in the morning. Just two bat-files and two actions in taskscheduler.

I send you some (not all because PC had to do hard reset) error messages. Hope it can help in your bug testing. Sorry about the quality, it’s just photos from the hooked up projector since the PC is headless.
Best Regards,

Interesting that your last screen shot quotes the error code 0xc0000142. This seems like a Windows problem, not something to do with Roon per se.

Hey @Peter_Olausson,

I appreciate you taking a moment to join the community and share the issue you’ve ran into. I’m sorry for the trouble this is causing.

Did you get a chance to try the suggestions in the article mentioned by @Geoff_Coupe?

@Geoff_Coupe thanks a million for chiming in :slight_smile:

Apologies for the troubles, @Peter_Olausson

This isn’t something we are seeing reported by others, and we aren’t seeing this on our end, but we are happy to help get to the bottom of this! First, can you try temporarily disabling and firewall or antivirus that may be running on the machine? Is there any change after doing so?

If not, would you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)?


I have solved the unstable version 1.8 crash by stopping and restarting it twice a day. Just a line in a bat-file activated by windows task scheduler. Starting 08.00, stopping 16.00, restarting 16.01 and stopping 00.00.
Works fine for me but I’m looking forward to a stable production version. A little of shame to release this unstable version that has caused a lot of people problems. Especially for us who trusted in you and payed for a life time license.
Best Regards,
Software developer for 35 years with big customers like Akzo Nobel, Atlas Copco, Sandvik Bacho, Siemens Elema, one of the Swedish Political Parties and more…
Always with customer satisfaction and trust in the first room

1 Like

I didn’t know I had to change setup from version 1.7 to version 1.8.
Haven’t got any serious suggestions for changing from 1.7 to 1.8.
Just want to repeat, 1.7 and before worked without problems.
Running on an ASUS VivoMini VC65 (i5, 8GB, SSD) dedicated headless, clean installation just with TIDAL HiFi. Guys with expensive Roon Nucleus also seems to have problems…
Haven’t got any message that a certain minor release should solve the problems so I have not tested without restating the last days.

I’m certainly not a computer expert as you are, but I guess any software update might create some sort of issue that could affect some users for one reason or another. Since the majority of Roon customers don’t have this issue, seems like it would be a good idea to work with Roon in an attempt to identify and resolve the issue. I agree that might be a PITA.

PS: I’ve had a lifetime license and Roon Nucleus for over 16 months with no issues.

To me that looks like memory management issues.

Have you tried uninstalling and reinstalling Roon?

I’m not windows expert but these look like hardware errors to me. More specifically memory errors. With new features requires a larger memory footprint. But, you know this from your software background. Since this is a dedicated Roon server I’m guessing you’re hitting memory regions with errors that you were not reaching on previous versions.

I’d run memory tests or pull sticks out to try and isolate the issue.

1 Like

I see a “CLR error 80004005.” Perhaps multiple .NET frameworks installed simultaneously.

I too have been in IT for decades. My intuition, based on the screenshots is that there’s something wrong with your PC’s hardware or system software that Roon needs to run isn’t working properly.

My guess is that it’s hardware. If you’re on Win10, I’d run the memory troubleshooter. (

I admit I’m guessing it’s memory because my rock solid Dell laptop started acting crazy and it turned out that one of the memory cards was bad - not bad enough to shut down the PC, but bad enough to drive me crazy trying to determine what was wrong.

Hello again
I have reinstalled Roon but not made a total removal before. Is there any “roon_clean_tool”? I normally use IOBit Pro uninstaller.
I ran HCI Design’s MemTest and Windows Memory Diagnostic, no problems.
I removed one old version of .NET and ran Microsoft .NET Framework Repair Tool and SFC /SCANNOW, no problems.
I now only have .NET 3.5 (which includes .NET 3.0 and .NET 2.0) and .NET 4.0 advanced services.

I will test a couple of days before total remove and reinstalling Roon.
Thanks for the tips,


Hello again
Now latest update of Roon has been running one week without major crash. Just stopping ones or twice every day, but that’s no problem for me. I’m happy with the situation now.
I guess it is the result of bug fixing and perhaps that I removed one .NET installation.
To bad that the installation program doesn’t have the capabilities to discover such easy glitches.
Thanks for all tips,

1 Like