Roon 1.8 Legacy (build 1126) not showing music library nor audio devices

Roon Core Machine

mid 2011 iMac running OS X Yosemite 10.10.5
Processor 2.5 GHz Intel Core i5
Memory 6 GB 1333 MHz DDR3

Networking Gear & Setup Details

Connected Audio Devices

Yamaha RXA3070 through HDMI

Number of Tracks in Library

12000

Description of Issue

Installed Roon Core 1.8 Legacy build 1126 and all my audio devices dissapeared and the Manage Audio Devices button in Settings–>Audio is not working. Also, even though the storage file path is ok, all my music has dissapeared as well (the files are in my hard disk but it seems that Roon is no longer reading them).

Maybe you need to restore from a recent Roon database backup.

Silly question but have you restarted the Roon Core since the update?

I’ve got the same problem after downgrading.

I’ve ensured permission are ok on my NAS drive for RoonServer user but in the app, it says Error loading folder.

I’ve restarted the core but to no avail.

I’m having a bit of a meltdown with all this tbh

Yes… Several times, in fact, to no avail

There are some peculiar problems for me with Roon on a Synology NAS drive. Roon still ‘remembers’ the old Synology workstation and I can’t add a folder in the Storage settings and get to the ‘root’ or the new Synology name if you know what I mean.

What I will try to do is de-install Roon 1.8 Legacy again, and remove the RoonServer user. And re-install. I’ll see what happens.

Sadly, I get an error too when trying to restore the only backup I have. I would have no problem with reloading my music files and doing all the setup again from zero as long as it works

Tried removing RoonServer user and re-installed Roon 1.8 legacy but still cannot access shared folders in Storage section. I’m running out of ideas…

Hi Alfredo_Freyre, are you using a NAS by any chance?

Hi Shon_Ellerton, no, I just have an external drive with all my FLAC files connected to the USB port of my Mac.

Hi Alfredo,

So if you go into Settings > Storage > then +Add Folder. Are you able to add a folder? I am unable because I get an error loading folder message.

Yes, I’m able to add the folder and it then appears listed in the storage section with a message like “files will be monitored in real time” of something similar, but nothing happens. If I try to Force Rescan the folder, the “thinking” icon appears for a moment but, again, nothing happens.
Thanks Shon

Hi Alfredo. That’s interesting. There’s something very wrong here. I’m going to try to download the latest pre Roon but not the legacy version to see what happens. RoonServer_Synology_DSM7_x86-64_20220216.spk

Actually, earlier today I had Roon Core 1.8 builds 1105 and 1126 (Legacy) installed concurrently, and 1105 (which was working fine this morning) had the same problem as 1126. Very strange. I sent both of them to trash and downloaded 1126 again, but the results were the same. Anyway, I’m going to sleep now, will continue tomorrow. Thanks !!

Here’s the upshot. Downgrading to Roon 1.8 Legacy on a synology breaks the Storage menu. I’m going to have to bite the bullet with Roon 2.0 and PRAY that Internet is stable. In parallel, I am exploring alternative media players as backup options. I have a Plex lifetime licence and use it for videos, so will use Plex to scan my music collection as well. Should be no issue on my beast of a NAS!