Roon 1.8 not starting on Win 10 PC

Core Machine (Operating system/System info/Roon build number)

Windows 10 running on Intel NUC8BEB
All drivers managed via Intel utility and up to date (Intel version)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NA (Roon not starting)

Description Of Issue

Previous installation of 1.7 running as a remote. Updated to 1.8 and all was good. Deauthorised 1.7 ROCK core and registered my 1.8 Win 10 machine as a core. An iPad remote connected fine and all was good.

Re-authorised 1.7 ROCK core and connected a 1.7 iPad remote without issue, but 1.8 Windows Roon will no longer start. Just get the animated Roon icon. Re-boot has not fixed it.

one other detail in case useful: on attempting to start Roon, very briefly there is a large white rectangle (I run dark theme) on the background, then I just get the dark screen with the Roon icon, hanging.

Decided I had nothing to lose on my Windows machine in going for a full uninstall of Roon and starting again, and Roon is now running. Clearly something went amiss in the 1.8 update.

1 Like

I have the same issue except I can not get Roon to Run on my pc. The icon does nothing. it doesn’t even look like it attempts to start. Not sure how to resolve it. I have not heard a word back from Roon about this.

sorry to hear that. I run Win 10 on an Intel NUC with an M.2 SSD C: drive, and 1.7 Roon used to start instantly. With the full uninstall of 1.8 and then reinstallation I can get 1.8 to start now, but it’s a very ponderous start-up, I see the Roon icon for a fair while before it starts properly, and the database scan has completed. Once 1.8 Roon eventually starts, the Windows client seems responsive, it’s just the start-up that’s really slow now.

Hey @ACvitus,

Thanks for bringing this up and sorry for our delay in replying.

While your graphics drivers may be up to date, if it was an automatic Windows update, they prove to be unreliable many times.

Could you and @Michael_DePaola, please try manually reinstalling the graphics drivers after downloading them directly from the manufacturer’s website?

We’ve seen this resolve similar issues to yours in the past.

Thanks in advance :pray:

In my case a full uninstall/reinstall of Roon fixed the startup issues on Windows without touching the graphics driver install.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.