Roon 1.8 on macOS Big Sur - Crashing on launch [Solved]

It’s hard to comment on the upgrades because the whole program crashes every time I open it. I wanted to try out the new classical features so I searched for Vivaldi and hit the play button. It responded with an error that the tracks selected were unplayable so I scrolled down and chose a Four Seasons track. I think the first one. I maximized the software and it promptly became unresponsive. So I force quit the software and opened it again. It immediately froze. So I deleted the software and reinstalled it. Once again it immediately freezes after it loads the previous state. I can’t figure out how to delete the previous state because I don’t know where it is stored. This is pretty frustrating. After those 5 emails I was pretty excited about 1.8… I shouldn’t have held my breath. Hopefully the software engineers are hard at work fixing this mess! I’m sure they are.

1 Like

Ummm, you’re normally supposed to say how you love 1.8 and how everything is just fine and dandy.


Ok this is how you clear the previous state:

Go → Computer → Macintosh HD → Users → [your user name]

With this window open hit {Command + Shift + .} this will display the hidden files

Navigate to the Library folder

Rename or Delete the Roon folder you can just rename it to RoonBKUP or something like that then open Roon. Roon will restart in a clean state and you’ll have to reconnect to your core. Hope this helps any other macOS users out there who run into a crash issue like this.

1 Like

I am also running Big Sur on Apple’s M1 chip. No issues here… I had the same crashes as everybody in the beginning but ever since the first bugfix, all is fine.

1 Like

Big Sur 11.2.1. No issues here since Build 756.

I am also running the latest build. This crash occurred with the latest build (756).

Probably need more details. Are you running just as remote or is your Core local / local files. Are you streaming? What does your audio endpoint look like? USB, network, ?

I’m using Intel Mac Big Sur as remote only without issue.

M1 Mac, Big Sur, but running Roon ROCK. So the Mac is remote only. No issues.

M1 Mac Mini - Big Sur - Roon 1.8 is stable and faster than 1.7 - noticeably speedier on my Macs, iPhones, iPads and AppleTV all on most recent OS (including Intel and M1 Macs) - Everything has been more stable than 1.7 so I must be one of the luck ones.

Mac computer is a remote. NUC running latest core. No issues controlling it from android/iOS the saved current state of the Roon macOS app was causing the crash every time the app was relaunched. I can’t repeat the issue, I’ve tried a few times. I still get Track Unavailable errors when trying to play classical music that are not local files. I’ve got both Tidal and Qobuz and both accounts currently logged in and working. Since I deleted the user Roon folder (the user/[username]/library/roon directory) it is working.