Roon 1,8 to 2.0

Roon Core Machine

I am runnen Roon on a MacBook pro 13 inch Wirth latest update of Mac Os
I am tryning to download Roon 2,0 to be able to run Arc. The 2,0 download is responing with mistake message… What do I have to do to get 2,0 in place


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

can’t down load toon 2.0

    1. List item

Where are you?

Hi I am in Norway

Hi @Dag_Age_Bore,

I’m sorry you’re having trouble and for the delay in responding. Let’s take a look at things.

Can you try and download the installer via my Link and see what happens?

If you’re still getting an error message, please provide a screenshot or photo here so we can see what’s going on.


Thank you Wes. ride your link but still have the same issue. The message in Norwegian says a mistake occured with downloading. I have English message on iPhone . Please see screenshots of both

Hope you can help based on this
best regards

Hi @Dag_Age_Bore,

Thank you for giving that a shot. I decided to enable diagnostics on your account and found an issue with the MacBook. It’s an older one that is running a version of OSx that is not supported with 2.0 unfortunately. Roon had to make some changes to implement new features and at the same time; open more doors for future features.

Here’s what you need to do to get back up and running:

First, download Roon 1.8 legacy via this Link. This should work for you this time.

On your remotes (iPad, iPhone, Android etc), go to the app store and search for Roon legacy. You should find an app there that will replace your current app. This will bring all of your devices to the same version and get you back up and running.


Thank you Wes,
Followed your instructions and the MacBook 13 from 2016 running on Mac OS Montery 12,6 is working as a core on 1,8 My iPad Pro from 2018 works as a remote. In Apple App Store I could not fine Roon Legacy only remote and labs beside Arc.
My iPhone pro 11 running on IOS 16 is not working as remote. I am able to run with Macboo and iPad.
Are you telling me that if I upgrade my MacBook to the latest model I will be able to run all on 2,0 and the get Arc?


Hi @Dag_Age_Bore,

Let me make sure we’re on the same page. When I look at diagnostic I see what version you are on for Roon and your operating system. It’s possible that something isn’t displaying correctly. Are you saying that you are in fact running Monterrey 12.6? This is what I show:

Roon: Dags-MacBook-Pro

Last Updated : 32 minutes ago

OS : Mac OS X 10.16.0 - RoonVersion: 1.8 (build 931) stable

Can you confirm?

This is the Mac OS as screenshot I took just now

Best regards


Thank you for this. I will come back with the next steps for you. Your situation is defying the norm so I’ll discuss it with development for us.


It’s Roon Remote (Legacy).

Hi @Dag_Age_Bore,

Let’s try this link and see what happens.

Your core is reporting your OS incorrectly and might be leading to the issues. The link above is a direct link to Roon’s installer for 2.0.

If this doesn’t work let me know. I’ve been speaking with the team responsible for the update servers so you have our ears!


Thank you Wes. I still get the same mistake that its a mistake when downloading 2,0.
Glad that your looking into it. Really like Roon and would like to have the latest version 2.0. !,8 is not bad and I’m still enjoying but would lake all the latest including Arc.
Do not know where your based, I am in Norway, its evening so I have some duties, will check again tomorrow
tks Wes

1 Like

Hi @Dag_Age_Bore,

It looks like I gave you the wrong link.

Try this Link instead and let me know, please.

Washington State, USA is where I am by the way. Enjoy your evening.


Hi Wes,
It worked I am now on 2,0 on Mac, iPhone and iPad .
Thank you for your patience and support

Very happy it worked out, tks to you


1 Like

Ps Arc works as well. Happy endings . Thank you again, Dag


@Dag_Age_Bore This pleases me to no end!

Enjoy the music, my friend.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.