Roon 1.8 UI unresponsive, still plays music though

Core Machine (Operating system/System info/Roon build number)

Roon Server on QNAP NAS
Version : 1.8 (build 764) stable
QPKG-Version : 2020-07-15

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Orbi AX6000 wifi 6, Netgear 8 port 1gb switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB → Topping D90

Description Of Issue

When i run Roon 1.8 build 764 (64 bit) on my Windows 10 desktop, i can listen to music, browse artists etc until i minimize the window. Once i unminimize, the ui is frozen - but music is still playing, and i can switch tracks in the UI and with multimedia keys on keyboard.

Anyone else seeing this?

Hi, I’m far from knowledgable (so might be leading you down a dead end), but to me this sounds like an issue with your Win 10 PC - the Core is still responding.

If you have access to a smartphone/tablet, can you run a Roon app to see if the Core is responsive to the remote during UI freezes on your PC?

Have you updated your graphics driver from the manufacturer’s website (and for that matter is Windows up to date)?

Looking at your PC’s Task manager, is Roon using a lot of resources when frozen?

1 Like

Win10 pro up to date, Core is responsive when UI freeze happens - (used android phone to change songs etc, responsive on mobile device) - NVidia graphics driver are up to date. Roon is using low resources. Pretty mysterious.

Yep, it is strange.

What are the specs of your Win 10 machine and the NAS?

Do you have anything running like whisper… GeForce Experience? Or other screen capture software?

Have you tried running Windows (and Roon) under a lower resolution? Say 1080p, if it is already higher than that?

Sorry, not sure of anything else to suggest.

I’m assuming your network is running correctly - you can access the network share on the NAS from the Windows file explorer? That kind of thing…

1 Like

Win10 Machine is beefy. AMD 5950X/Nvidia 3090/32GB DDR4 RAM/3TB NVME - to your GeForce Experience question, its installed but i did not enable any overlays etc, so i just use it to keep drivers up to date and optimize game settings basically.

NAS is fine, all other clients can play - but its a QNAP with a dual core proc and 16GB RAM.

I have tried to run roon in compat mode for win7/8 - same issue pops up.

Network is solid. Pushing near GB over wifi, all network shares are available etc.

This is driving me mad.

Hi, Patrick. Your frustration is understandable, hopefully you won’t have too long to wait until support can help.

I still think it is something to do with the interaction between your graphics driver and Roon.

I know it is a pain, but could you uninstall GeForce Experience, and restart and test…

Install the GeForce 3090 driver directly from the website:

Using the custom install, to remove previous settings. And then restart…

Unlikely to help, but something to try:

I’m assuming your DAC is connected directly to the NAS? Can you try unplugging the DAC from the NAS, restart the NAS and PC, and then run Roon on your PC.

With the Roon app running on your Android, use Settings>Audio from your PC to enable the smartphone as an endpoint, if you see any other devices in Settings>Audio can you disable those.

Check that Private Zone is disabled for the Android from cog icon>Device setup.

Then using the PC to play tracks, navigate the UI, etc… does it still freeze when you minimize?

Fun note here: I was experiencing this issue when upgrading to 1.8, fresh install of 1.8 works immediately after install, but after closing and restarting hangs on launch.

Further work done on my end - i tired to clean out roon files left behind after uninstall to get a true “clean install” but had no luck. I ended up completely reinstalling windows and now things mostly work. Sometimes roon has trouble finding my DAC, but eventually does.

So. Solution for me? Complete fresh install of Windows.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Core Machine

Roon Server on MacOS 10.14.6, roon version 1.8 build 795

Network Details

zyxel switch, wired ethernet for all devices

Audio Devices

windows laptop->caldigit ts3 plus->mytek brooklyn USB

Description of Issue

Same problem as described in this locked thread- GUI was freezing after being minimized but music would continue to play and respond to stop/play/skip track commands.

In my case this was definitely graphics driver related. I experienced the problem while running nvidia’s driver 466.47- this is on an alienware m15 r3, gpu is a 2080 Super. I also noticed while running that driver that I could not get the laptop to run the refresh rate on my display any higher than 60hz- despite previous drivers supporting 120hz when hdr was disabled.
I did a clean install of 466.77 today, lo and behold, 120hz is back if I disable HDR. I checked Roon with HDR enabled and disabled- no freezing.
So in my case, Roon’s gui would freeze while running 466.47, and also showed some evidence of bugs outside of Roon (120hz not available).
With 466.77, the gui does not freeze.

Hey @Nicholas_Kalister,

Thanks a whole lot for letting us know of this - to keep things unified, I’ve moved your thread into this one, so your post continues the conversation.

Thank you for sharing the solution :pray:

I am having this exact same problem. Running 1.8 build 795. Using RTX 3090 with latest nVidia drivers 471.11. Using resolution 3840x2160 at 120 HZ, 32-bit color depth, 10 bpc, RBG, full dynamic range. I have already tried clean reinstalling nvidia drivers and roon.

I can make the problem temporarily go away if I go into nvidia control panel, change switch it to 8 bpc then back to 10 bpc, but ultimately it comes back. I haven’t figured out what triggers it to come back again. But it does appear that it’s something related to the graphics drivers/settings.

Hope this description helps the team solve the problem. It’s incredibly annoying. I’m trying to “retrain” myself not to minimize Roon.