Roon 1.8 - Weird behavior concerning track count and double entries

Core Machine

Core: Roon 1.8 (build 795) stable (64bit), Windows 10 Pro x64 (10.0.19042 Build 19042), Core i7 5820K, 16GB

Network Details

Fritz!Box7530 @100Mbit/s

Audio Devices

USB - iFi ZEN DAC V2

Library Size

1.395 (and growing)

Description of Issue

Dear Support-Staff,

I’m completely new to Roon and I love the program so far but there are a few things that still bug me and keep me from pulling the trigger for the lifelong subscription.

I came upon some weird behavior concerning my Track count before and after I added my Tidal subscription.

Before Tidal subscription was added:


After Tidal subscription was added and Tidal Library tracks are filtered out:

With my subscription removed the “Tracks” Section in “My Library” shows 1395 Tracks, but after I add Tidal and filter out it’s Library it goes down to 1392.

I’m curious why that is since the local files haven’t changed.


Also, some titles I have locally and in my Tidal favorites show up as double. That’s kind of annoying and confusing at the same time. As far as I know the metadata is identical.

Comparison via the Export-feature in Excel:




On a side note, I also miss following functions (but I'm not sure if this is the right place for that):
  • To display the MQA Symbol not only for albums but for tracks too

  • To add and remove titles to and from my Tidal-Playlists

  • To export my Tidal-Playlists as .m3u file (without the files obviously) so I can comfortably add them to Tidal using a Third-Party Tool like https://www.tunemymusic.com

  • To get access to the personal Mixes generated by Tidal

  • A refresh button for Tidal-Playlists if they have been changed (I’m aware that there is an option to manually sync the library in the settings, it would just be much more comfortable this way)

  • To add the Option “Add to Playlist” in the left-click menu (when clicking on a title)

  • That the local tracks are preferred if they are played during Tidal playback or radio

  • That the search function in Roon only displays the highest Quality of a song (or at least prefers and/or highlights it)

  • To stream it over the Internet (but the workaround with a VPN works fine for me, would be nice if this function would come native to Roon)

  • A more reliable Search engine (some playlists can’t be found over Roon where they are easily found over the Tidal app)

Thanks in advance for your help
Matthias

Hi @Matthias,

Welcome to the community.

What might have happened has to do with the fact that at least 3 Tidal albums (possibly more) match albums already in your local library. In this case, Roon decided that 3 of the Tidal versions are better quality than your local version and have made them Primary Version.

You can read more about Duplicates and Hidden Versions here:

You can find them by going into Album Browser and Focus on Duplicates.

Let us know if that helps.

Cheers, Greg

Hi @Greg, thank you for your fast response.

Assuming that your theory is correct and Roon chooses the Tidal version over my local one, why does it still show both of them? It would suggest that Roon “knows” my local track and still decides to display it along the Tidal version, even though it compared them and found that the quality is better/worse. It would make more sense to me if the better track is kept and the other one is hidden.

Either way there seems to be a problem with how Roon identifies the tracks. I went through all of my unidentified (and double) tracks and found that Roon doesn’t always recognizes them. If I try to use the “Identify Album” option it’s a 50/50 Chance that it doesn’t find the correct album information in Roons database even if a Tidal counterpart is in the library. If the correct Information was found the double entry goes away as well.

Is there a way to “copy” the album information from Tidal tracks and add it to the local tracks if the manual search doesn’t find the correct information?

I also found that sometimes Roon displays an entirely different title than in the Tidal application. There seems to be the same problem as discussed before but after I manually searched with the “Identify Album” option the double entries went away and the naming of the local files was applied.


Little suggestion to improve the Knowledge Base:

There is an easier way to configure autologon for Windows (when using Roon with Headless Servers).

The Guide in question is following:

My suggestion would be to use the Autologon-Tool from Sysinternals. The Autologon-Tool can be downloaded directly from Microsoft under this link:

This downloads a .zip file that contains the AutoLogon.exe. You have to run this tool as Administrator so it asks for Privileges. After that a small window opens were you can add your Username and Password.

To enable the Autologon click the Button “enable”. The password is stored encrypted in the Registry. To disable the Autologon click the Button “disable”.

This way you don’t have to make any manual changes to the registry, it’s also a lot faster and eliminates user error.

Best regards
Matthias

Hello @Matthias,

I don’t think I can apologize enough for taking this long to get back to you :pleading_face: . I am so sorry for the delay!

Also, thank you very much for engaging with the community in the meantime (thanks @Greg for chiming in!) and trying to better understand Roon and to find a solution to the issues you’ve ran into.

I was wondering if there’s anything we can help with at this point. We’d love to! :nerd_face:

Also, thank you for your feedback about our guide, and for carefully researching a better solution. I’ve looped in one of our technicians so they can take a closer look and make any necessary changes :pray:

We’ll be in touch!