Roon 1.8 won't start: QNAP, iMac, iPad, iPhone

Roon 1.8, just updated today. Can’t find build number because Roon won’t start!

Roonserver 2021-02-01 (just updated firmware and software today) QNAP TS-253A with Roon installed on Samsung SSD, USB connected

MacOS Big Sur 11.1, iOS 14.4.2 (iPad and iPhone)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity router with Ethernet connection to audio system

Eero mesh WiFi network in the house (~300 Mbps)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/ect.)

Meridian AC200 and QNAP, Ethernet connection through Pakedge switch (I’m a little vague on the technical details)

Meridian 218s connecting to Meridian DSP5200.2 and DSP3200.

Sonos Connect with Ethernet connection to switch, with dual identification as both Roon and Sonos endpoints for some of the players.

Description Of Issue

We just got back from a 2-week trip. On return, I could not get Roon to load. I downloaded updated firmware for QNAP and downloaded the latest Roonserver, restarted the QNAP and all 3 devices, then Roon said I needed to update software, which I did.

Now when I try to open Roon on my iMac, iPad, or iPhone, I get a white screen with the moving loudspeaker logo…and it just keeps moving but nothing else happens. Help!

I also tried deleting the Roon app from my iPhone and reinstalling it. It asked if I wanted to connect to the QNAP NAS, I clicked yes, and then got to the same startup screen with the moving logo (black semicircle and moving lines)…and it just stayed there without doing anything else. I also deleted the app on my iMac, then downloaded Roon for Mac from the Roonlabs webpage, and opened it: same result. The software for the NAS all works fine. When I open Roonserver on the QNAP, I see this. I’m not sure what the box on the right means–I’ve never done anything to the Roonserver app in the past.

I also tried removing Roonserver from the QNAP and reinstalling it from the QNAP App store. I saw my albums for a second, then got a screen saying that the software on my QNAP needed to be updated. When I clicked on update, I got the same interminable logo. Here are the log files. Hope this helps.


For Balance here, I have a Qnap TVS 471, latest QNAP build as it updated the other day. i3 with 16GB Ram.
Roon updated last night without issue.

I’m happy for you, Chris, but that doesn’t help me. I tried enabling Multimedia Functions on the NAS but that didn’t do anything. I also tried changing the Roonserver database location from “Roon Server” to “Roon Storage” (see screenshots), but then I got the “waiting to connect to remote core” message so that didn’t seem to be the right move.

Since I’m on a Mac, none of the comments on other threads about Windows updates apply here.

I’m a lifetime subscriber and have been quite happy with Roon for the past 3+ years, so this is disturbing.


(maybe @crieke can weigh in here? You’ve been very helpful before with my QNAP problems, Christopher.)

Let’s hope Chris can help you fault find this. My comment was to show that this is not universal across all Qnap set ups. Something is badly wrong for you… Good luck

OK, some progress. After a couple of reinstallations of Roonserver and power cycling the QNAP, I was able to get Roon to start. BUT…nothing will play because it can’t find any audio devices. Also I can only see my albums on the QNAP, not my larger collection on TIDAL, even though I can see everything when I sign in to my account on the TIDAL website. (Why do I have a QNAP when I only have 150 albums? The salesman was very persuasive. And I’ve been overjoyed with the Meridian speakers he sold me, so I’m not complaining.)

You really need to tag @support

@support @crieke Hey, guys, I may live near Silicon Valley but I’m completely flummoxed here. Now I’m back to Roon not starting at all. It’s been 4 days of being unable to listen to music. My daughter is coming for a visit soon, and she’s a musician.

Can someone please help? Here are the most recent logs. Let me know if you need more info.

Thanks very much.


Did you sort it out? I have the same problem. I use MacBook Air, suddenly Roon stop running.

@support @crieke @danny
I know this has been a rough year for everyone and you all have lots on your plate, but I posted this a week ago and have heard nothing. I still can’t play any music at all.

When I’ve had occasional support questions in the past, I’ve always received very prompt, helpful replies, so this seems unusual.

I’ve provided my system information, sent logs (twice), and have done as much as I know how to do, but still all I get when I try to start Roon is this (I can’t upload a motion capture, but you get the idea):

Screen Shot 2021-04-20 at 12.37.48 PM

I’m a lifetime subscriber, and I’m generally not a complainer, but I’m starting to get a little annoyed. I appreciate Chris and Jesus weighing in, but I could use some expert help.

Also, if I’m doing something wrong in trying to get this question answered, someone please let me know.


@support I’m refreshing this thread, since I’ve seen a number of responses from support today to requests that are a few days old. Mine has been here for 9 days, so hopefully someone will see it. I still can’t get Roon to start. Thanks!


Hello @Mark_Cohen ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Can you please verify this aspect again? Setting up a fresh database is a good test here to try to differentiate from a database issue vs a hardaware issue.

After changing the location you will also need to specify the Roon Remotes to connect to the new Core instance, so in this case, you will want to “use another Core” on the remotes.

After changing the database location, please verify if you are seeing the issue on the fresh database prior to restoring from a backup. Thank you!

Thanks for the reply, Noris. But I’m afraid your suggestion assumes a level of sophistication that I don’t have. Could you please be a little more specific about what steps I should take? I don’t fully understand what all of Roon’s files are and where they’re located. I’m a retired physician and am somewhat computer literate, but I don’t know which “database” you’re referring to or how to interpret the instructions on the Roonserver app on the QNAP.


Hi @Mark_Cohen

Here are the steps you’ll need to take:

  • Stop RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart RoonServer
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Thanks, Dylan, that was the kind of step-by-step instructions I needed, and it worked! :grinning:

I have some suggestions going forward that might make this a little easier from the (non-technical) user’s viewpoint.

1 - Consider putting a banner at the top of the support page that says something like “We apologize, but we’ve had a large number of requests and it’s taking us much longer than usual to respond. If you haven’t received a response within (3? 5? 7??) days, please refresh your request.”
That would have lowered my blood pressure a lot!

2 - Your instruction said “Find the folder that says RoonServer,” but I found two, one in Roon Storage and one in Roon Server:

I finally decided to rename the one that’s in the Roon Server folder, and that worked, but more specific instructions would help. I really have no idea how the QNAP/Roon file structure works.

Which brings me to…
3 - @crieke, your assistance in the past has been really helpful, and I appreciate all of the hard work you’ve done to set up and maintain RoonServer on NAS. But I think it would be helpful to add some more specific instructions on your page regarding file locations and structure. I confess that I didn’t write down the steps I took when I set up Roon on my new system 3 years ago. So this info on your Roon for QNAP instructions left me a bit in the dark:

I seem to recall that when I first set it up there were some instructions on the Roon website about how to set up the database on QNAP, including where to put the files and what to name them, but I can’t find them now. Would it be possible to add that info to your webpage? As well as how to rename and reinstall the files if there’s a problem.

That being said, thanks again for the assistance–I’m so happy I can finally hear my music again, and can continue to enjoy and explore Roon’s new look!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.