Roon 2.0.5 Still Not Working For Me!

Roon 2.0.5 Still Not Working For Me!!! I have had to force quit about 5 times already. What is the manual fix that was mentioned in the annoucment…?


I moved your post from the #uncategorized area to #support so that people actually see it

Hi Anthony,

Please fill out the support information request form below. Since, you posted in a section outside of Support, it did not fill in for you.


Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Hey @Anthony_McCarthy,

Following up on this thead, are you still running into issues with Roon 2.0? If so, please provide more information around your full system setup :+1:

I’ll be on standby for your reply

1 Like

Hi Benjamin… I have decided to stay on Roon Legacy 1.8 for my main MacPro workstation… as my Bluesound Node 2i Gen 2 and Audio Engine A5+ speakers are attached to that machine and that runs macOS Mojave, while my MacBook Pro runs Ventura 13.1… I need volume control on my MacPro, so best keep the core app running on that machine. Unfortunately, I’m unable to update my MacPro any further… so I will wait until I receive delivery of the new MacPro M2 Extreme Apple Silicon when it launches some time in 2023.

Thank you for your follow-up :slight_smile:

Merry Christmas & A Happy New Year to all the Team at Roon!! :slight_smile:


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.